Fix hesiod not reading /etc/hesiod.conf; thanks to Jacob Welsh for reporting; bug...
authorCharlie Shepherd <masterdriverz@gentoo.org>
Sat, 9 Dec 2006 10:05:10 +0000 (10:05 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Sat, 9 Dec 2006 10:05:10 +0000 (10:05 +0000)
Package-Manager: portage-2.1.2_rc2-r2

net-dns/hesiod/ChangeLog
net-dns/hesiod/files/digest-hesiod-3.0.2-r2 [new file with mode: 0644]
net-dns/hesiod/hesiod-3.0.2-r2.ebuild [new file with mode: 0644]

index d07975398c0af4754b7c6542137e2447a8b04351..14d9a0adf9025b198ab7f18538d97b317c263da0 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-dns/hesiod
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/ChangeLog,v 1.20 2006/10/09 21:26:29 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/ChangeLog,v 1.21 2006/12/09 10:05:10 masterdriverz Exp $
+
+*hesiod-3.0.2-r2 (09 Dec 2006)
+
+  09 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+  -hesiod-3.0.2-r1.ebuild, +hesiod-3.0.2-r2.ebuild:
+  Fix hesiod not reading /etc/hesiod.conf; thanks to Jacob Welsh for
+  reporting; bug 157555
 
   09 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> hesiod-3.0.2-r1.ebuild:
   Added ~x86-fbsd keyword.
diff --git a/net-dns/hesiod/files/digest-hesiod-3.0.2-r2 b/net-dns/hesiod/files/digest-hesiod-3.0.2-r2
new file mode 100644 (file)
index 0000000..36e651e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0362311e80fb1e029a1588cbbd09ad57 hesiod-3.0.2.tar.gz 31974
+RMD160 b2abfdebc9874a4d111748c687b63e275220316b hesiod-3.0.2.tar.gz 31974
+SHA256 ee0ff39ad2445728360e1550de3c18d48813b3f9359ea3ad8a49f71ffb314c25 hesiod-3.0.2.tar.gz 31974
diff --git a/net-dns/hesiod/hesiod-3.0.2-r2.ebuild b/net-dns/hesiod/hesiod-3.0.2-r2.ebuild
new file mode 100644 (file)
index 0000000..143dfe5
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2-r2.ebuild,v 1.1 2006/12/09 10:05:10 masterdriverz Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="system which uses existing DNS functionality to provide access to databases of information that changes infrequently"
+HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
+SRC_URI="ftp://athena-dist.mit.edu/pub/ATHENA/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       filter-flags -fstack-protector
+
+       #Patches stolen from RH
+       epatch ${FILESDIR}/hesiod-${PV}-redhat.patch
+       autoconf || die "autoconf failed"
+
+       for manpage in *.3
+       do
+               if grep -q '^\.so man3/hesiod.3' ${manpage}
+               then
+                       echo .so hesiod.3 > ${manpage}
+               elif grep -q '^\.so man3/hesiod_getmailhost.3' ${manpage}
+               then
+                       echo .so hesiod_getmailhost.3 > ${manpage}
+               elif grep -q '^\.so man3/hesiod_getpwnam.3' ${manpage}
+               then
+                       echo .so hesiod_getpwnam.3 > ${manpage}
+               elif grep -q '^\.so man3/hesiod_getservbyname.3' ${manpage}
+               then
+                       echo .so hesiod_getservbyname.3 > ${manpage}
+               fi
+       done
+}
+
+src_compile() {
+       econf --sysconfdir /etc || die 'econf failed'
+       emake || die 'emake failed'
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+}