net-misc/memcached: security cleanup (bug #711208)
authorSam James (sam_c) <sam@cmpct.info>
Wed, 25 Mar 2020 16:27:25 +0000 (16:27 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 25 Mar 2020 21:22:36 +0000 (22:22 +0100)
Bug: https://bugs.gentoo.org/711208
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15111
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/memcached/Manifest
net-misc/memcached/memcached-1.5.14.ebuild [deleted file]

index 1993d5af57dc0add1ac88b9eb58db515052842a5..df163e4481932cefdd9e4b5cb24ae73bb1904b4d 100644 (file)
@@ -1,3 +1,2 @@
-DIST memcached-1.5.14.tar.gz 485076 BLAKE2B 729b4b708e921184bfedadbb02b0304eb09dcebbbd1420605deb608dcd7dea25a8982ca0f387f237a1a6412b4682372018c593396ef9bff5aa0fa901c0fdafd6 SHA512 d06083d971d0a40195b4dfb252a3bf7c3a0d20b2dcad56726ff9e0b87ba84024309300516dad40181f1b7af4d9c4f35924383977c5e1ff9b5f13d2ef05f684ed
 DIST memcached-1.5.22.tar.gz 532713 BLAKE2B 90787522f36d9d4389438334572725df18050ae67bda2d97cde67b01492ca81772ddf7e83e02f71031ca909402a68f3db085ef6bece6e032ce580676a8a722f3 SHA512 19804c2847679eb018a0221b0717ebbcd2cd33b7f03176cc0d77b7405152dc944d3f5c39d0d81fcb6c08a2fa9317959e25587e7cb50718fdb6675288b2b078aa
 DIST memcached-1.6.2.tar.gz 536527 BLAKE2B e350ee10ed74d68206baa009fa49e30e6563a21fd617fc30c1c2695642f6a5f85662acc40471d903a54c26153ca904d1ce9fb3bcbc7bae5d06431069872ca812 SHA512 e695c1292fc85280be3d337990c37f6fcf85e1a73870d541b993335b12f33b31516b477c30169a40c7b5d24fac8c842fdc5f1f48348c5cafa593040229349640
diff --git a/net-misc/memcached/memcached-1.5.14.ebuild b/net-misc/memcached/memcached-1.5.14.ebuild
deleted file mode 100644 (file)
index a249427..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils flag-o-matic systemd user
-
-MY_PV="${PV/_rc/-rc}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="High-performance, distributed memory object caching system"
-HOMEPAGE="http://memcached.org/"
-SRC_URI="https://www.memcached.org/files/${MY_P}.tar.gz
-       https://www.memcached.org/files/old/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug sasl seccomp selinux slabs-reassign test" # hugetlbfs later
-
-RDEPEND=">=dev-libs/libevent-1.4:=
-       dev-lang/perl
-       sasl? ( dev-libs/cyrus-sasl )
-       seccomp? ( sys-libs/libseccomp )
-       selinux? ( sec-policy/selinux-memcached )"
-DEPEND="${RDEPEND}
-               test? ( virtual/perl-Test-Harness >=dev-perl/Cache-Memcached-1.24 )"
-
-S="${WORKDIR}/${MY_P}"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
-       epatch "${FILESDIR}/${PN}-1.2.2-fbsd.patch"
-       epatch "${FILESDIR}/${PN}-1.4.0-fix-as-needed-linking.patch"
-       epatch "${FILESDIR}/${PN}-1.4.4-as-needed.patch"
-       epatch "${FILESDIR}/${PN}-1.4.17-EWOULDBLOCK.patch"
-       sed -i -e 's,-Werror,,g' configure.ac || die
-       sed -i -e 's,AM_CONFIG_HEADER,AC_CONFIG_HEADERS,' configure.ac || die
-       eautoreconf
-       use slabs-reassign && append-flags -DALLOW_SLABS_REASSIGN
-
-       # Tweak upstream systemd unit to use Gentoo variables/envfile.
-       # As noted by bug #587440
-       sed -i -e '/^ExecStart/{
-                       s,{USER},{MEMCACHED_RUNAS},g;
-                       s,{CACHESIZE},{MEMUSAGE},g;
-                       s,OPTIONS,MISC_OPTS,g;
-               };
-               /Environment=/{s,OPTIONS,MISC_OPTS,g;};
-               /EnvironmentFile=/{s,/sysconfig/,/conf.d/,g;};
-               ' \
-               "${S}"/scripts/memcached.service
-       default
-}
-
-src_configure() {
-       econf \
-               --disable-docs \
-               $(use_enable sasl)
-       # The xml2rfc tool to build the additional docs requires TCL :-(
-       # `use_enable doc docs`
-}
-
-src_compile() {
-       # There is a heavy degree of per-object compile flags
-       # Users do NOT know better than upstream. Trying to compile the testapp and
-       # the -debug version with -DNDEBUG _WILL_ fail.
-       append-flags -UNDEBUG -pthread
-       emake testapp memcached-debug CFLAGS="${CFLAGS}"
-       filter-flags -UNDEBUG
-       emake
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dobin scripts/memcached-tool
-       use debug && dobin memcached-debug
-
-       dodoc AUTHORS ChangeLog NEWS README.md doc/{CONTRIBUTORS,*.txt}
-
-       newconfd "${FILESDIR}/memcached.confd" memcached
-       newinitd "${FILESDIR}/memcached.init2" memcached
-       systemd_dounit "${S}/scripts/memcached.service"
-}
-
-pkg_postinst() {
-       enewuser memcached -1 -1 /dev/null daemon
-
-       elog "With this version of Memcached Gentoo now supports multiple instances."
-       elog "To enable this you should create a symlink in /etc/init.d/ for each instance"
-       elog "to /etc/init.d/memcached and create the matching conf files in /etc/conf.d/"
-       elog "Please see Gentoo bug #122246 for more info"
-}
-
-src_test() {
-       emake -j1 test
-}