dev-java/snakeyaml: EAPI 5 bump. Set SLOT back to 0.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 8 Jan 2016 09:14:01 +0000 (09:14 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 8 Jan 2016 10:28:31 +0000 (10:28 +0000)
Package-Manager: portage-2.2.26
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/snakeyaml/snakeyaml-1.9-r2.ebuild [new file with mode: 0644]

diff --git a/dev-java/snakeyaml/snakeyaml-1.9-r2.ebuild b/dev-java/snakeyaml/snakeyaml-1.9-r2.ebuild
new file mode 100644 (file)
index 0000000..52a0c49
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
+HOMEPAGE="https://bitbucket.org/asomov/snakeyaml"
+SRC_URI="https://snakeyaml.googlecode.com/files/SnakeYAML-all-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+       java-pkg_clean
+
+       # Easier to use java-pkg-simple.
+       rm -v pom.xml || die
+}
+
+src_install() {
+       java-pkg-simple_src_install
+       dodoc AUTHORS src/etc/announcement.msg
+}