games-arcade/gnome-robots: bump to 3.32.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 20 Oct 2019 08:47:09 +0000 (11:47 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 20 Oct 2019 17:38:02 +0000 (20:38 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
games-arcade/gnome-robots/Manifest
games-arcade/gnome-robots/gnome-robots-3.32.0.ebuild [new file with mode: 0644]

index be2d4430a48618c76976404d8815cb06d42600c5..bd1fef65183c6a0ae76ef6ae64b34a97d4e3d034 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-robots-3.22.3.tar.xz 540824 BLAKE2B 2f6943b97878d37da8c8a59cc7752b2c0eba35bc9eea1cf4b8a221fbae59ec4730af2ae71b25f2e946ee1edcabdb1a72a67cb1754350728b737fa26e3f9193e3 SHA512 d521527d9ceab16f4e3c64677044c87e46f38291ff126cc2280f69100750cb0317e6ad45e8a0abaa4dad38b67b958cac66653c33ba7760a410354f9190c02399
+DIST gnome-robots-3.32.0.tar.xz 422684 BLAKE2B bf66057da9ed52ffe641d28aa522d7851a1ac7881369d1329507beffdeb3f9dc6a46988993c899783576e8c63730245dd340b62267809d1334515dabc2d599e4 SHA512 b037d576eea45843ae4c13ddf284a598931b295257688f6fa458fb4e33b987c01dd70d34007703b3f7bcb97cf8aa306e6473e4c24e5ee0253f1beaafcff1c6f7
diff --git a/games-arcade/gnome-robots/gnome-robots-3.32.0.ebuild b/games-arcade/gnome-robots/gnome-robots-3.32.0.ebuild
new file mode 100644 (file)
index 0000000..3087314
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=x11-libs/gtk+-3.15:3
+       >=dev-libs/glib-2.32:2
+       >=gnome-base/librsvg-2.36.2:2
+       dev-libs/libgnome-games-support:1=
+       >=media-libs/libcanberra-0.26[gtk3]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}