media-libs/libfreehand: Fix build against ICU-65
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 1 Nov 2019 19:01:00 +0000 (20:01 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 1 Nov 2019 19:01:00 +0000 (20:01 +0100)
Closes: https://bugs.gentoo.org/699096
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch [new file with mode: 0644]
media-libs/libfreehand/libfreehand-0.1.2.ebuild

diff --git a/media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch b/media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch
new file mode 100644 (file)
index 0000000..a246649
--- /dev/null
@@ -0,0 +1,26 @@
+From af3197f795625f5188602073205a34369698b6df Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 4 Oct 2019 01:46:12 +0200
+Subject: [PATCH] Add missing semicolon to fix build with icu 65.1
+
+Change-Id: I7a0b0d600e9f7770245a7485813a944bfac4f088
+Reviewed-on: https://gerrit.libreoffice.org/80224
+Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
+Tested-by: Miklos Vajna <vmiklos@collabora.com>
+---
+ src/lib/libfreehand_utils.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/libfreehand_utils.cpp b/src/lib/libfreehand_utils.cpp
+index 439c457..32f23e0 100644
+--- a/src/lib/libfreehand_utils.cpp
++++ b/src/lib/libfreehand_utils.cpp
+@@ -162,7 +162,7 @@ void libfreehand::_appendUTF16(librevenge::RVNGString &text, std::vector<unsigne
+   while (j < length)
+   {
+     UChar32 c;
+-    U16_NEXT(s, j, length, c)
++    U16_NEXT(s, j, length, c);
+     unsigned char outbuf[U8_MAX_LENGTH+1];
+     int i = 0;
+     U8_APPEND_UNSAFE(&outbuf[0], i, c);
index f27b47bb13986b3488ff5f3840c57e6c7b374544..ac35aa0e43ab0f9fe227938bf999dfa7fd45572d 100644 (file)
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
        test? ( dev-util/cppunit )
 "
 
+PATCHES=( "${FILESDIR}/${P}-icu-65.patch" )
+
 src_prepare() {
        default
        [[ -d m4 ]] || mkdir "m4"