dev-python/oauth2client: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:14:23 +0000 (12:14 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:14:23 +0000 (12:14 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/oauth2client/Manifest
dev-python/oauth2client/oauth2client-2.0.1.ebuild [deleted file]
dev-python/oauth2client/oauth2client-2.2.0.ebuild [deleted file]
dev-python/oauth2client/oauth2client-4.1.2.ebuild [deleted file]

index 74bde410e8e6278acf2a694cacaf49a4cf8ca8e4..4ad1dc297cab6d1e7674269ed43be210793a99c1 100644 (file)
@@ -1,4 +1 @@
-DIST oauth2client-2.0.1.tar.gz 153127 BLAKE2B f7e7ccbe42effedfb94abe4f78e2ea02867aa75ca7ff794d6db6cdb2e039d4a7d55df79df3a7f8777be215fc4aafb1dda08a23b81eaa66d64c9b2580045c158f SHA512 66179a604418a8aee9ca9dbfc5ad18356d5130a588e85f4dab3330feef194af2114bc2eb18ec625acf791938e4d7f78ee55284f45a67a48c775676697ce2b183
-DIST oauth2client-2.2.0.tar.gz 167484 BLAKE2B 60c7fc941548874f436df094a94e97312983f88af8ca472c998cb7121662363793423d420fa3e7e83032b82a3fd22a76f9331a60e3099785ef82d3fb5a781356 SHA512 1e23c3f655e955dbf0cdb2b78613768ca4c6eb4336b555e3553da212fd762ba12329584f108d8145810228cf44da018675b38dd152b06e58be4eb18d4f8127c6
-DIST oauth2client-4.1.2.tar.gz 184731 BLAKE2B 09ae16a94b1f6b3eedb02ac10d660d8fda78faa82da5fed75b2a40308049c7d78951d593352f2e02c7bd9255e75b50c20996d12f451c20e1dcf2c32f54008b07 SHA512 908f0e32f0ef76c3eb86ee34118d4100bc08fa34aa89c561793bf8c55078f07611935ee6aecb6d2ae2f7e96a18ac3bc25af0321fe564f26042ff2bb5eab30b18
 DIST oauth2client-4.1.3.tar.gz 185589 BLAKE2B 6cd61448e0d55cef7f2ba640c8cbb50ac83e76d0993391eb0acb3e156f937fcdee80576c9d45d505235a9f266495069664ccbfafd649a4e2d7a0990517ee8cb6 SHA512 80f49e09a6dd6767307a2c278544926fbf20b4f55e4cf83563ac7a7c1043622bd3c8c7fcf6de62896b623ca8c7947b309a5e6bf2b7cb0fccff3ff7634386b287
diff --git a/dev-python/oauth2client/oauth2client-2.0.1.ebuild b/dev-python/oauth2client/oauth2client-2.0.1.ebuild
deleted file mode 100644 (file)
index d9abd69..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/google/oauth2client"
-SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
-       >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
-       !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}"/${P/_p/-post}
-
-# Needs network
-RESTRICT=test
-
-python_prepare_all() {
-       sed \
-               -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
-               -i setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests || die
-}
diff --git a/dev-python/oauth2client/oauth2client-2.2.0.ebuild b/dev-python/oauth2client/oauth2client-2.2.0.ebuild
deleted file mode 100644 (file)
index 1e40b24..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/google/oauth2client"
-SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
-       >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
-       !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}"/${P/_p/-post}
-
-# Needs network
-RESTRICT=test
-
-python_prepare_all() {
-       sed -i \
-               -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
-               setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests || die
-}
diff --git a/dev-python/oauth2client/oauth2client-4.1.2.ebuild b/dev-python/oauth2client/oauth2client-4.1.2.ebuild
deleted file mode 100644 (file)
index d8b73c6..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/google/oauth2client"
-SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="|| ( $(python_gen_useflags 'python*') )"
-
-RDEPEND="
-       >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
-       >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
-       >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
-       dev-python/keyring[${PYTHON_USEDEP}]
-       !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}"/${P/_p/-post}
-
-python_prepare() {
-       # keyring is not fuly supported by pypy yet, because dbus-python can't support pypy
-       # oauth2client -> keyring -> secretstorage -> dbus-python
-       # https://github.com/mitya57/secretstorage/issues/10
-       case $PYTHON in
-               pypy|*pypy|*pypy3|pypy3) \
-                       find "${BUILD_DIR}/.." -name '*keyring*py' -delete ;;
-       esac
-}
-
-python_test() {
-       nosetests -e appengine -e django_util -e test_multiprocess_file_storage -e test_bad_positional || die
-       # appengine - requires appengine
-       # django_util - requires django
-       # test_multiprocess_file_storage - requires fasteners
-       # test_bad_positional - expects TypeError, gets ValueError
-}