dev-python/funcparserlib: Bump to EAPI=7
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 08:28:27 +0000 (10:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 12:26:12 +0000 (14:26 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
new file mode 100644 (file)
index 0000000..721fe2f
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://pypi.org/project/funcparserlib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       local m=unittest
+       cd "${BUILD_DIR}"/lib || die
+       "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       local DOCS=( doc/*.md )
+       distutils-r1_python_install_all
+}