sys-libs/libfaketime: don't call CC directly for tests
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 2 Mar 2020 23:48:40 +0000 (00:48 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 3 Mar 2020 00:03:04 +0000 (01:03 +0100)
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-libs/libfaketime/libfaketime-0.9.6-r2.ebuild
sys-libs/libfaketime/libfaketime-0.9.7.ebuild

index d157aa32edfbdcb600a6198342b6795013e677c1..538aad5ced37edf6f1d85ce8aad4154ee8f97e56 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -37,7 +37,7 @@ multilib_src_compile() {
 }
 
 multilib_src_test() {
-       multilib_is_native_abi && emake test
+       multilib_is_native_abi && emake CC="$(tc-getCC)" test
 }
 
 multilib_src_install() {
index 0a558c5d178bfa02c43c826cdb755c655fa5613c..6166040c60df24e9896c884bcbd56ece41ce4c55 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -37,7 +37,7 @@ multilib_src_compile() {
 }
 
 multilib_src_test() {
-       multilib_is_native_abi && emake test
+       multilib_is_native_abi && emake CC="$(tc-getCC)" test
 }
 
 multilib_src_install() {