Fix madwifi compilation with ROOT != "/".
authorHenrik Brix Andersen <brix@gentoo.org>
Mon, 27 Feb 2006 21:49:53 +0000 (21:49 +0000)
committerHenrik Brix Andersen <brix@gentoo.org>
Mon, 27 Feb 2006 21:49:53 +0000 (21:49 +0000)
Package-Manager: portage-2.0.54

net-wireless/hostapd/ChangeLog
net-wireless/hostapd/hostapd-0.4.8.ebuild
net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
net-wireless/hostapd/hostapd-0.5.0.ebuild
net-wireless/hostapd/hostapd-0.5.1.ebuild
net-wireless/wpa_supplicant/ChangeLog
net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild
net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild
net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild
net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild

index c3e8e0c9f5b4cf170a65f45ddb8127af70db1365..b413e283b58f4e210dbbfe48a716e060a10dd2af 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-wireless/hostapd
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.57 2006/02/19 21:54:03 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.58 2006/02/27 21:45:59 brix Exp $
+
+  27 Feb 2006; Henrik Brix Andersen <brix@gentoo.org> hostapd-0.4.8.ebuild,
+  hostapd-0.5.0.ebuild, hostapd-0.5.0-r1.ebuild, hostapd-0.5.1.ebuild:
+  Fix madwifi compilation with ROOT != "/".
 
   19 Feb 2006; Michael Hanselmann <hansmi@gentoo.org>
   hostapd-0.4.7-r2.ebuild:
index 5a2584aefa3e24ad13627f21ecdaf6563d542945..12424742fddde5d1f41fbd0cc6fa136113b73bcc 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.8.ebuild,v 1.1 2006/02/14 12:09:44 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.8.ebuild,v 1.2 2006/02/27 21:45:59 brix Exp $
 
 inherit toolchain-funcs
 
@@ -59,8 +59,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"          >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index 8d0c7c3a269888f311f4eebaa4e106ecb5465ec1..271743354596fa6f130704fd74f9f658a21a5e1c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
 
 inherit toolchain-funcs
 
@@ -60,8 +60,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"          >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index 62bcdf3789c354f5a96f5a6bd53060c25b280e0a..53b126067caed667c8dad5a0926bde3001048182 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
 
 inherit toolchain-funcs
 
@@ -60,8 +60,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"          >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index 0932def5360323f81203c108e054fef6e2e66449..fb3c6404e42403c389c8f38d2501069bbb18bd42 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
 
 inherit toolchain-funcs
 
@@ -60,8 +60,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"          >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index ecd7f24393d4f11c391091d754c28ee1a65cc5ce..af5284eb1d3263b0045c26ba98e339e7e1135e64 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-wireless/wpa_supplicant
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.51 2006/02/14 12:11:55 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.52 2006/02/27 21:49:53 brix Exp $
+
+  27 Feb 2006; Henrik Brix Andersen <brix@gentoo.org>
+  wpa_supplicant-0.4.7-r1.ebuild, wpa_supplicant-0.4.8.ebuild,
+  wpa_supplicant-0.5.0-r1.ebuild, wpa_supplicant-0.5.1.ebuild:
+  Fix madwifi compilation with ROOT != "/".
 
 *wpa_supplicant-0.4.8 (14 Feb 2006)
 
index 48293bd1bde4a1ba84ef2c80e2f499a87cab5263..948f39ccd12010f882a58008dfa42df35c2f67c6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild,v 1.2 2006/01/17 20:07:22 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
 
 inherit eutils toolchain-funcs
 
@@ -77,8 +77,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"           >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index a52b5d0c0834f48eb9a69b5c5adfe9318bfaeba5..f61958e612a17e5db700323cff9def9a6825d21e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild,v 1.1 2006/02/14 12:11:55 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild,v 1.2 2006/02/27 21:49:53 brix Exp $
 
 inherit eutils toolchain-funcs
 
@@ -77,8 +77,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"           >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index 799ccaf90c6ef6cbdacf83a5d924054127a1dc2e..c8ec8be4a207808256a65fb860833d9e93ccc1c9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild,v 1.2 2006/01/17 20:07:22 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
 
 inherit eutils toolchain-funcs
 
@@ -78,8 +78,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"           >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }
 
index 197a0f4de8624ea5c8315337d64e1efb748fc3d0..637f3f49d63a080b24356d9f81b5c599656a2576 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild,v 1.2 2006/02/06 13:45:56 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
 
 inherit eutils toolchain-funcs
 
@@ -78,8 +78,8 @@ src_unpack() {
 
        if use madwifi; then
                # Add include path for madwifi-driver headers
-               echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
-               echo "CONFIG_DRIVER_MADWIFI=y"          >> ${CONFIG}
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
        fi
 }