app-emulation/qemu: Fix MissingTestRestrict
authorMichał Górny <mgorny@gentoo.org>
Thu, 12 Dec 2019 14:55:15 +0000 (15:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 12 Dec 2019 14:58:31 +0000 (15:58 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-emulation/qemu/qemu-4.0.0-r50.ebuild
app-emulation/qemu/qemu-4.1.0.ebuild
app-emulation/qemu/qemu-9999.ebuild

index d585d58e2726a0ea5c23a40436c7280de4c5d4bd..428fbaafe4df974513fcc5fcfc857f8c24978dbc 100644 (file)
@@ -47,6 +47,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
 use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
 IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
 
+RESTRICT="!test? ( test )"
 # Allow no targets to be built so that people can get a tools-only build.
 # Block USE flag configurations known to not work.
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
index d0bec4380dbc5ac8bff7568e9ad0d707e8ee2368..e8f34c66cab12c3cb3dca8b77e0de79810d370e3 100644 (file)
@@ -53,6 +53,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
 use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
 IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
 
+RESTRICT="!test? ( test )"
 # Allow no targets to be built so that people can get a tools-only build.
 # Block USE flag configurations known to not work.
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
index d024b50206917a45ae1cae44e4c15b13ebc8ce44..3bf1f06000f91621b642bd1ce4d87ee1ae647fd3 100644 (file)
@@ -53,6 +53,7 @@ use_softmmu_targets=$(printf ' qemu_softmmu_targets_%s' ${IUSE_SOFTMMU_TARGETS})
 use_user_targets=$(printf ' qemu_user_targets_%s' ${IUSE_USER_TARGETS})
 IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
 
+RESTRICT="!test? ( test )"
 # Allow no targets to be built so that people can get a tools-only build.
 # Block USE flag configurations known to not work.
 REQUIRED_USE="${PYTHON_REQUIRED_USE}