kernel-2.eclass: Revert "avoid lexicographical compare on versions, bug #705246"
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 26 May 2020 22:01:34 +0000 (23:01 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 26 May 2020 22:02:59 +0000 (23:02 +0100)
This reverts commit 8493b3a1823ea5f24f44ea317ceced513b6722ed.

Syntax errors:

```
kernel-2.eclass: line 1081:
  syntax error near `${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}'
kernel-2.eclass: line 1081:
  syntax error near `${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}'
kernel-2.eclass: line 1081:
  `if [[ ${KV_MAJOR} -ge 3 || ver_test ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} -gt 2.6.24 ]] ; then'
kernel-2.eclass: line 1081:
  `if [[ ${KV_MAJOR} -ge 3 || ver_test ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} -gt 2.6.24 ]] ; then'
```

Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
eclass/kernel-2.eclass

index d69182045c5b3caa7dccb080fad819b75f06e609..07af8d8ab2c5b56081780e697a3b70e26d8b652e 100644 (file)
@@ -1015,7 +1015,7 @@ postinst_sources() {
        #       K_SECURITY_UNSUPPORTED=deblob
 
        # if we are to forcably symlink, delete it if it already exists first.
-       if [[ ${K_SYMLINK} -gt 0 ]]; then
+       if [[ ${K_SYMLINK} > 0 ]]; then
                [[ -h ${EROOT}usr/src/linux ]] && { rm "${EROOT}"usr/src/linux || die; }
                MAKELINK=1
        fi
@@ -1078,7 +1078,7 @@ postinst_sources() {
        KV_PATCH=$(ver_cut 3 ${OKV})
        if [[ "$(tc-arch)" = "sparc" ]]; then
                if [[ $(gcc-major-version) -lt 4 && $(gcc-minor-version) -lt 4 ]]; then
-                       if [[ ${KV_MAJOR} -ge 3 || ver_test ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} -gt 2.6.24 ]] ; then
+                       if [[ ${KV_MAJOR} -ge 3 || ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} > 2.6.24 ]] ; then
                                echo
                                elog "NOTE: Since 2.6.25 the kernel Makefile has changed in a way that"
                                elog "you now need to do"
@@ -1272,7 +1272,7 @@ unipatch() {
        # do not apply fbcondecor patch to sparc/sparc64 as it breaks boot
        # bug #272676
        if [[ "$(tc-arch)" = "sparc" || "$(tc-arch)" = "sparc64" ]]; then
-               if [[ ${KV_MAJOR} -ge 3 || ver_test ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} -gt 2.6.28 ]]; then
+               if [[ ${KV_MAJOR} -ge 3 || ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} > 2.6.28 ]]; then
                        if [[ ! -z ${K_WANT_GENPATCHES} ]] ; then
                                UNIPATCH_DROP="${UNIPATCH_DROP} *_fbcondecor*.patch"
                                echo
@@ -1521,7 +1521,7 @@ kernel-2_src_unpack() {
        # fix a problem on ppc where TOUT writes to /usr/src/linux breaking sandbox
        # only do this for kernel < 2.6.27 since this file does not exist in later
        # kernels
-       if [[ -n ${KV_MINOR} && ver_test ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} -lt 2.6.27 ]] ; then
+       if [[ -n ${KV_MINOR} &&  ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} < 2.6.27 ]] ; then
                sed -i \
                        -e 's|TOUT      := .tmp_gas_check|TOUT  := $(T).tmp_gas_check|' \
                        "${S}"/arch/ppc/Makefile