media-fonts/fira-code: add 3.1
authorHans de Graaff <graaff@gentoo.org>
Tue, 5 May 2020 06:56:51 +0000 (08:56 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 5 May 2020 06:56:59 +0000 (08:56 +0200)
Starting with this version the TTF font files are installed. This is the
recommended install on Linux and should provide better rendering
quality.

Thanks to Andrew Udvare for pointing this out.

Closes: https://bugs.gentoo.org/717286
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
media-fonts/fira-code/Manifest
media-fonts/fira-code/fira-code-3.1.ebuild [new file with mode: 0644]

index 789a075b95053c724fa8837a9c04cf32f5d65aa4..3a0f003eb6d28db49eb1797eaf6a96145fb76fbd 100644 (file)
@@ -1,4 +1,5 @@
 DIST FiraCode-Regular-Symbol.zip 9337 BLAKE2B b901cc37ad796f3a68d8b9e492aa35570c2d718fc84920b5b23c0a055e46c19916a7ec6b2c0a0adba650161c5a032761d46b303de64bddd81696adf960e3e541 SHA512 2570958b0f4b28ded52327150b67118d693d6bc6f483be3e3147ddda1c5870ab21f1b64938e4abc1030080455976c0d33ae3925b51660fd2c8b5428b5b0f8eb7
 DIST fira-code-1.207.tar.gz 6640459 BLAKE2B ccd61201c5fe9d8755f0822d413df66184763f57b69965c22a6aceacda9ba117d4ffc0fbacb85e2c9202cd00de4b942ed36b599c3ecc46781fd3085b5a4ee688 SHA512 b0c555489f196c958a2abda4108fea10f13d2e62a94f26eebdc894e31ba5a34591e2a0214c4a8fb93fdb423b3e40c2e11045774a462c37faae24db1c85e4ce0e
 DIST fira-code-2.tar.gz 7100481 BLAKE2B 1ca41276c56b6edb174620224d2a0a72750cd29c48c71a350d033896e2ff6d59454236f193b6dc95f8f5ccd338951ac52f5c2e27c6a5286589382af938bc76f8 SHA512 313f11f1550d964119c2576bc988ca7d009ebd670c93b3c4a29583f91499166816ed326fdb5a5082ed7c7a33c49263e627a3356cc739aa1a8e34689820081399
+DIST fira-code-3.1.tar.gz 5665465 BLAKE2B d1ad5d8e2d217d9dc1f06b9ac52dcf87f4f108aab1469399f0d1fb011f3619a1ce1c85803213da33a7b7f6e48fffddc194627b3fe560f7340a6a41b15d822062 SHA512 6acb941664a773a1186e6b6150ce747977fc95963d4be8756de05eddf7c2785ba0a5eac8319361779f6e747e8cd1edadeff1a72045cdeb3b152ce5bb2c1b77dd
 DIST fira-code-3.tar.gz 5665172 BLAKE2B c27861867102b788da151e9b5ed3b8a1d3e610f9f40d6facfc7f850fb15ff6903bc4e0579674e4732b52bf1477b3f9bc223158c59991d4517af3476f7f5d819f SHA512 2518b2fe1e2454da32a023e93c38358b0c89691f2f47b2e26e9ccf583109911b83d73880800fe02f556e9ed5888edf08e447360628eedb4e7a693a2f9e778520
diff --git a/media-fonts/fira-code/fira-code-3.1.ebuild b/media-fonts/fira-code/fira-code-3.1.ebuild
new file mode 100644 (file)
index 0000000..73fe57c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Monospaced font with programming ligatures"
+HOMEPAGE="https://github.com/tonsky/FiraCode"
+SRC_URI="https://github.com/tonsky/FiraCode/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/tonsky/FiraCode/files/412440/FiraCode-Regular-Symbol.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/FiraCode-${PV}"
+FONT_S="${S}/distr/ttf"
+FONT_SUFFIX="ttf otf"
+
+DOCS="README.md"
+
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+       default
+       mv "${WORKDIR}"/*.otf "${FONT_S}" || die
+}