dev-python/python-magic: Add patch to fix tests
authorMatt Turner <mattst88@gentoo.org>
Tue, 3 Mar 2020 06:15:52 +0000 (22:15 -0800)
committerMatt Turner <mattst88@gentoo.org>
Tue, 3 Mar 2020 06:17:04 +0000 (22:17 -0800)
Closes: https://bugs.gentoo.org/663610
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch [new file with mode: 0644]
dev-python/python-magic/python-magic-0.4.15-r1.ebuild

diff --git a/dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch b/dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch
new file mode 100644 (file)
index 0000000..4dd362e
--- /dev/null
@@ -0,0 +1,26 @@
+From 18c909c4c98463d8292a7d1733aec007f178f1e5 Mon Sep 17 00:00:00 2001
+From: Adam Hupp <adam@hupp.org>
+Date: Sat, 11 Jan 2020 21:57:24 -0800
+Subject: [PATCH] Hopefully fix #105
+
+---
+ test/test.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/test/test.py b/test/test.py
+index 62e8a03..c15227d 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -78,7 +78,11 @@ def test_descriptions(self):
+                  'gzip compressed data, was "test", last modified'
+                  ': Sun Jun 29 01:32:52 2008, from Unix',
+                  'gzip compressed data, was "test", last modified'
+-                 ': Sun Jun 29 01:32:52 2008, from Unix, original size 15'),
++                 ': Sun Jun 29 01:32:52 2008, from Unix, original size 15',
++                 'gzip compressed data, was "test", '
++                 'last modified: Sun Jun 29 01:32:52 2008, '
++                 'from Unix, original size modulo 2^32 15'
++                ),
+                 'text.txt': 'ASCII text',
+             }, buf_equals_file=False)
+         finally:
index 8f25dcdad7e6a7aa640a7777dc671bb4d171c5c2..e17297d181385111db8e4d504e5952240b4877fd 100644 (file)
@@ -31,6 +31,8 @@ PATCHES=(
        "${FILESDIR}/${P}-fix-gzip-test.patch"
        # https://github.com/ahupp/python-magic/commit/4bda684f8b461cc1f69593799efcf6afe8397756
        "${FILESDIR}/${P}-fix-jpeg-test.patch"
+       # https://github.com/ahupp/python-magic/commit/18c909c4c98463d8292a7d1733aec007f178f1e5
+       "${FILESDIR}/${P}-fix-gzip-test-2.patch"
 )
 
 python_test() {