app-misc/spacenavd: Support GCC 10
authorSebastian Pipping <sping@gentoo.org>
Fri, 31 Jan 2020 23:36:57 +0000 (00:36 +0100)
committerSebastian Pipping <sping@gentoo.org>
Fri, 31 Jan 2020 23:42:51 +0000 (00:42 +0100)
Closes: https://bugs.gentoo.org/706966
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch [new file with mode: 0644]
app-misc/spacenavd/spacenavd-0.7.ebuild

diff --git a/app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch b/app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch
new file mode 100644 (file)
index 0000000..485aa6c
--- /dev/null
@@ -0,0 +1,24 @@
+From 081182f1675bb69eec58d92698f1ba2f23466d3f Mon Sep 17 00:00:00 2001
+From: John Tsiombikas <nuclear@member.fsf.org>
+Date: Sat, 1 Feb 2020 01:19:14 +0200
+Subject: [PATCH] GCC 10 changes the default from -fcommon to -fno-common, so
+ we need to set it explicitly now. Closes github bug #17.
+
+---
+ Makefile.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 9eba102..abf62c9 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -7,7 +7,8 @@ ctl = spnavd_ctl
+ CC = gcc
+ INSTALL = install
+-CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -I$(srcdir)/src -I/usr/local/include $(add_cflags)
++CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -fcommon \
++               -I$(srcdir)/src -I/usr/local/include $(add_cflags)
+ LDFLAGS = -L/usr/local/lib $(xlib) $(add_ldflags)
+ $(bin): $(obj)
index 05eb105d31642213f2fae91855f6f4e6748203f1..6a4e1d73addcfc9036c13ea9557a1adacbd3cb15 100644 (file)
@@ -17,6 +17,10 @@ IUSE="X"
 RDEPEND="X? ( x11-apps/xdpyinfo x11-libs/libXi )"
 DEPEND="${RDEPEND}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-gcc10.patch
+)
+
 pkg_setup() {
        CONFIG_CHECK="~INPUT_EVDEV"
        ERROR_CFG="Your kernel needs INPUT_EVDEV for the spacenavd to work properly"