dev-util/pkgconf: bump to 1.0.2
authorMike Gilbert <floppym@gentoo.org>
Tue, 25 Oct 2016 19:29:05 +0000 (15:29 -0400)
committerMike Gilbert <floppym@gentoo.org>
Tue, 25 Oct 2016 19:29:31 +0000 (15:29 -0400)
Package-Manager: portage-2.3.2

dev-util/pkgconf/Manifest
dev-util/pkgconf/pkgconf-1.0.2.ebuild [new file with mode: 0644]
dev-util/pkgconf/pkgconf-9999.ebuild

index 366e7dbc5c1a7c9932c1913878e4d3488f64a03a..520a37e0bca5350a1bbb26c52dd892c414df8735 100644 (file)
@@ -1,3 +1,4 @@
 DIST pkgconf-0.9.11.tar.bz2 86489 SHA256 3bdae1b2672133943dc0dda694ed57074f8b03c3fea10efb215d76d3cabe2c3b SHA512 21313ef29afcaa7c49a8cb512ecd3a821693945c22fb1a670ada74f41bca320e1b9ffb64e79adc2c33cb86822b74ddc850fadb16ddcde7eb805b81a50096992f WHIRLPOOL 7442a456af7e959c86f318ee74ec89883cc4e2ad16c9708f98d8ab30cdcf71ea7ef13f7e0f9bf945717b1dea8a317ffc5322878f88a5084c2dcbdc2aeafaf4d2
 DIST pkgconf-0.9.12.tar.bz2 87109 SHA256 7ec8b516e655e247f4ba976837cee808134785819ab8f538f652fe919cc6c09f SHA512 efe13db7a46992eb44ead493fc12b3fc6a5567e0206f701b6c48d9b5eb0bc90fcc9ae7a7e08ae641bb10df869287e5b68291701d4013d6cf27bd2b1518c29192 WHIRLPOOL 9fa7336e111f29648f5c37310bdeb2266bead1b86ff18183cfb57c06054916d235da20a5723bd364497d20a1f4db399eaf77f38c0bfc1519f2b7b825ab4666d0
 DIST pkgconf-1.0.1.tar.gz 362653 SHA256 45ce2f6ab032451345185b800badd77c054040879bd2e56225dafc7fbe583cf1 SHA512 b379ed366327eb4de3a7ed732be58a3757fdcd231637f0fbc2f9b762fda08173244d05fd853d683cfa6bdad90f1d8ee663b3eae9aee024456ef46e8a021e7122 WHIRLPOOL ba9a26874d14b6dfd62858da1b50397bc0aa9637bfe0824d4911f4df1e430e60a9f589242f8dc60a792b16f5201f9e0944d637e0d3a4749a211b976459152d69
+DIST pkgconf-1.0.2.tar.xz 247972 SHA256 a7c67f8603c0d0400be17b2efac0fdc9ff46625f7e50aefe4ad31eff248115dd SHA512 679c9033489076ba5691c3a830b8e300c6cb2dc9e7eeffa1a478c681c7f1cc49896b0b5d0d069b14804a5c9bc31115ba672b1f724cd6282ce26d54945a5a8a42 WHIRLPOOL e7bcb19eba08ff271a470a1c8bba13810951c20e79b7dea5352ea20b8b519d4462892c623e8383b540f5af3b6daf302386b8b1831bfed3d7d143f33cb9e0830a
diff --git a/dev-util/pkgconf/pkgconf-1.0.2.ebuild b/dev-util/pkgconf/pkgconf-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..0a4a2ab
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
+       inherit autotools git-r3
+else
+       SRC_URI="https://distfiles.dereferenced.org/pkgconf/${P}.tar.xz
+               https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+               ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
+               ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+fi
+
+inherit multilib-minimal
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       pkg-config? (
+               !dev-util/pkgconfig
+               !dev-util/pkg-config-lite
+               !dev-util/pkgconfig-openbsd[pkg-config]
+       )"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/pkgconf
+)
+
+src_prepare() {
+       default
+
+       [[ ${PV} == "9999" ]] && eautoreconf
+       if use pkg-config; then
+               MULTILIB_CHOST_TOOLS+=(
+                       /usr/bin/pkg-config
+               )
+       fi
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       econf $(use_enable strict)
+}
+
+multilib_src_install() {
+       default
+
+       if use pkg-config; then
+               dosym pkgconf /usr/bin/pkg-config
+       else
+               rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+       fi
+}
index eff8a40f53404e872afa0c0b103b4dab61e1c356..0a4a2ab274f041f353b1ff7354db22fd9ae13bbe 100644 (file)
@@ -8,7 +8,8 @@ if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
        inherit autotools git-r3
 else
-       SRC_URI="https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.gz"
+       SRC_URI="https://distfiles.dereferenced.org/pkgconf/${P}.tar.xz
+               https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.xz"
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
                ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
                ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"