app-emulation/crossover-bin: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 09:01:42 +0000 (10:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:10:34 +0000 (17:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
24 files changed:
app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild
app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild
app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild
app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild
app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild
app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild
app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild
app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild
app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild
app-emulation/crossover-bin/crossover-bin-15.3.0.ebuild
app-emulation/crossover-bin/crossover-bin-15.3.1.ebuild
app-emulation/crossover-bin/crossover-bin-16.0.0.ebuild
app-emulation/crossover-bin/crossover-bin-16.2.5.ebuild
app-emulation/crossover-bin/crossover-bin-17.5.0-r1.ebuild
app-emulation/crossover-bin/crossover-bin-17.5.0.ebuild
app-emulation/crossover-bin/crossover-bin-17.5.1.ebuild
app-emulation/crossover-bin/crossover-bin-18.0.0.ebuild
app-emulation/crossover-bin/crossover-bin-18.1.0.ebuild
app-emulation/crossover-bin/crossover-bin-18.5.0-r1.ebuild [moved from app-emulation/crossover-bin/crossover-bin-18.5.0.ebuild with 96% similarity]

index 15750dd8078996d8955f99df5e6f92b75fee404a..78d5be269b3e8c4861cf405292c62c1df3fe98ca 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c00511cf666cead7362a4215c75172bb67a7f464..f9d5407086561eb2a53f1b109410da2bf89c79b8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index ba03accfe2276b43b95d5a3cc1213c1de56f5581..c96c8632eb57ee75815e47271caedf1a9d1083dd 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index cf4b4f10d80d7d9a5e73307144c19021ff0d91b7..7b3f30280c5019a8c415e6aed9b5177f011f213f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index c8154f99883d2f8d02e888ef1f1a6785665d5d21..f5a9ee2ded655751ce328f438d2446edb87f441c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index bdb0de9d05d2430b4a90250a3d167e3657583907..71dba5bd4ed3bd99338b75cf4998c65c1e340f56 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index bdb0de9d05d2430b4a90250a3d167e3657583907..71dba5bd4ed3bd99338b75cf4998c65c1e340f56 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index 79500b6a3914f958c32625f1ee56b53d3c075b44..35a162c94cac565f42e5c085496e27ee4bc4b080 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -37,8 +37,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index b3537aa9c934c5f709b1447cd36e1c08059a8689..b70ac3a77fd0dc56345e2ff80772dcaf25f1703a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index b3537aa9c934c5f709b1447cd36e1c08059a8689..b70ac3a77fd0dc56345e2ff80772dcaf25f1703a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index b3537aa9c934c5f709b1447cd36e1c08059a8689..b70ac3a77fd0dc56345e2ff80772dcaf25f1703a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index b3537aa9c934c5f709b1447cd36e1c08059a8689..b70ac3a77fd0dc56345e2ff80772dcaf25f1703a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index 00827f7ddb60132638373de37d65e934d3a29984..d3cb1e980327e244fbff176165af1db005cedfbf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index a160f02ad3ea1ba83101615a8d6961ad77e8ed4c..5096405e61990b4db37d8203f4d1a5d562941865 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index 006df8e971687a5cb2cce66fc31dcfe78fa0cdd5..96a7c42364feabd2d6673ee513bd737e22bd38a5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -36,8 +36,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index f2e4d02eaa7d7d1630a4dbd33dd5f2df8c645fe5..170b56d9e8848f587a706de6af4726c411e22370 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -48,8 +48,10 @@ BDEPEND="${PYTHON_DEPS}
 RDEPEND="${DEPEND}
        ${PYTHON_DEPS}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10:2[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
index f2e4d02eaa7d7d1630a4dbd33dd5f2df8c645fe5..170b56d9e8848f587a706de6af4726c411e22370 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -48,8 +48,10 @@ BDEPEND="${PYTHON_DEPS}
 RDEPEND="${DEPEND}
        ${PYTHON_DEPS}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10:2[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin
similarity index 96%
rename from app-emulation/crossover-bin/crossover-bin-18.5.0.ebuild
rename to app-emulation/crossover-bin/crossover-bin-18.5.0-r1.ebuild
index f2e4d02eaa7d7d1630a4dbd33dd5f2df8c645fe5..170b56d9e8848f587a706de6af4726c411e22370 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -48,8 +48,10 @@ BDEPEND="${PYTHON_DEPS}
 RDEPEND="${DEPEND}
        ${PYTHON_DEPS}
        !prefix? ( sys-libs/glibc )
-       >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/pygtk-2.10:2[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+       ')
        dev-util/desktop-file-utils
        !app-emulation/crossover-office-pro-bin
        !app-emulation/crossover-office-bin