net-misc/gsutil: Drop residual SocksiPy-branch reference
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Mar 2016 20:36:33 +0000 (20:36 +0000)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Mar 2016 20:44:39 +0000 (20:44 +0000)
Gentoo-Bugs: https://bugs.gentoo.org/show_bug.cgi?id=575720

Signed-off-by: Justin Lecher <jlec@gentoo.org>
net-misc/gsutil/gsutil-3.42.ebuild
net-misc/gsutil/gsutil-4.15.ebuild
net-misc/gsutil/gsutil-4.16.ebuild
net-misc/gsutil/gsutil-4.17.ebuild

index 7147e47c6e138463b5d60aa634f8b5fc17160bf2..19674d0f6dc855d05f3c746557e4a706fb42581b 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI="5"
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -38,6 +39,14 @@ PATCHES=(
        "${FILESDIR}/${PN}-3.37-drop-http_proxy-clearing.patch"
 )
 
+python_prepare_all() {
+       sed \
+               -e '/SocksiPy-branch/d' \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        export BOTO_CONFIG=${FILESDIR}/dummy.boto
        ${PYTHON} gslib/__main__.py test -u || die "tests failed"
index e8598a197435ac7904aa991753c9c94dface3a15..8a26913e2331b98a02788f16045157dfd7af7ce4 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI="5"
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -40,6 +41,14 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.15-use-friendy-version-checks.patch
 )
 
+python_prepare_all() {
+       sed \
+               -e '/SocksiPy-branch/d' \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        export BOTO_CONFIG=${FILESDIR}/dummy.boto
        ${PYTHON} gslib/__main__.py test -u || die "tests failed"
index 117830654c9ce42f7c01246a7d281cd600fcd336..b2ee088b544a430e9095e8c913e714c5d9631976 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI="5"
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -39,6 +40,14 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.16-use-friendy-version-checks.patch
 )
 
+python_prepare_all() {
+       sed \
+               -e '/SocksiPy-branch/d' \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        export BOTO_CONFIG=${FILESDIR}/dummy.boto
        ${PYTHON} gslib/__main__.py test -u || die "tests failed"
index 117830654c9ce42f7c01246a7d281cd600fcd336..b2ee088b544a430e9095e8c913e714c5d9631976 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI="5"
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -39,6 +40,14 @@ PATCHES=(
        "${FILESDIR}"/${PN}-4.16-use-friendy-version-checks.patch
 )
 
+python_prepare_all() {
+       sed \
+               -e '/SocksiPy-branch/d' \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        export BOTO_CONFIG=${FILESDIR}/dummy.boto
        ${PYTHON} gslib/__main__.py test -u || die "tests failed"