app-text/libnumbertext: --disable-static
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 16:07:35 +0000 (18:07 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 17:09:01 +0000 (19:09 +0200)
Closes: https://bugs.gentoo.org/723218
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/libnumbertext/libnumbertext-1.0.5-r1.ebuild [new file with mode: 0644]

diff --git a/app-text/libnumbertext/libnumbertext-1.0.5-r1.ebuild b/app-text/libnumbertext/libnumbertext-1.0.5-r1.ebuild
new file mode 100644 (file)
index 0000000..a0453ad
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Number to number name and money text conversion libraries"
+HOMEPAGE="https://github.com/Numbertext/libnumbertext"
+SRC_URI="https://github.com/Numbertext/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
+IUSE=""
+
+src_configure() {
+       econf \
+               --disable-static \
+               --disable-werror
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -type f -delete || die
+}