dev-python/passlib: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:34:03 +0000 (13:34 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:34:03 +0000 (13:34 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/passlib/Manifest
dev-python/passlib/passlib-1.7.1-r2.ebuild [deleted file]

index 2dc05f8ad0fb3cf9eddaf5fc25f3e07c1ca41b09..2da76b89308bae80fcee8c6ab6ebc3dd6a1f49e1 100644 (file)
@@ -1,2 +1 @@
-DIST passlib-1.7.1.tar.gz 645724 BLAKE2B f34e3bbc5a61ff71cc989fa26edb9f992909bfdcc6ca1b094ebc02fc9942eb1db1ea18fc3dd5bb7d9fcecf6b4bd82e93aba07c7ce63ec85452b5d7117a6e1968 SHA512 3d5f069cd4e44e5e87cdabc46845acbdd6c1eeedb7ce1f611aebee87b0f7af19009b6a47a10ec555fd84260b9f5c933c6429e325d30326de3869f05031674168
 DIST passlib-1.7.2.tar.gz 649654 BLAKE2B 40279113d9ff633cea47222f2d72af0abee78dc52a9b46adf66aaae213594eaae7f245cc80004f85b5055b882741b4bedfd81ee39132db23760d37a34e87ac6a SHA512 1ea0654b177b5ab2e1a7e5c3949642c34805ace6e4e4a0f82fafdb3f374edd99c667906ce598c335b668da049860648d5cbebb3e62d775898d5b0cb8cfc7bf53
diff --git a/dev-python/passlib/passlib-1.7.1-r2.ebuild b/dev-python/passlib/passlib-1.7.1-r2.ebuild
deleted file mode 100644 (file)
index 2c3f8d8..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~sparc x86"
-SLOT="0"
-IUSE="+bcrypt doc +scrypt test +totp"
-
-RDEPEND="bcrypt? ( dev-python/bcrypt[${PYTHON_USEDEP}] )
-       totp? ( dev-python/cryptography[${PYTHON_USEDEP}] )
-       scrypt? ( dev-python/scrypt[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
-       "${FILESDIR}/passlib-1.7.1-tests.patch"
-)
-
-RESTRICT="!test? ( test )"
-
-python_test() {
-       nosetests -v -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
-}