mail-client/thunderbird: allow LLVM 9.x
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 21 Oct 2019 19:59:14 +0000 (21:59 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 21 Oct 2019 19:59:34 +0000 (21:59 +0200)
Closes: https://bugs.gentoo.org/698120
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
mail-client/thunderbird/thunderbird-60.9.0.ebuild

index ac0b9acef568dc2673e14d085300ebd8bb868ffb..23f57c4db64f5e8da7f11145b85d4f648804840c 100644 (file)
@@ -32,7 +32,7 @@ if [[ ${MOZ_ESR} == 1 ]]; then
 fi
 MOZ_P="${PN}-${MOZ_PV}"
 
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
 
 inherit check-reqs flag-o-matic toolchain-funcs gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils autotools mozlinguas-v2 multiprocessing
 
@@ -117,6 +117,14 @@ DEPEND="${CDEPEND}
        >=sys-devel/binutils-2.30
        sys-apps/findutils
        || (
+               (
+                       sys-devel/clang:9
+                       !clang? ( sys-devel/llvm:9 )
+                       clang? (
+                               =sys-devel/lld-9*
+                               sys-devel/llvm:9[gold]
+                       )
+               )
                (
                        sys-devel/clang:8
                        !clang? ( sys-devel/llvm:8 )