app-crypt/johntheripper-jumbo: add 1.9.0
authorHans de Graaff <graaff@gentoo.org>
Sun, 14 Jul 2019 08:57:55 +0000 (10:57 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 14 Jul 2019 08:58:18 +0000 (10:58 +0200)
Fixes: https://bugs.gentoo.org/674656
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-crypt/johntheripper-jumbo/Manifest
app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild [new file with mode: 0644]

index 1cbbf2f69a98857669a036c2ac6386b009d2b02c..0afa7b836b3a172720c8e851569da3a72d717304 100644 (file)
@@ -1 +1,2 @@
 DIST JohnTheRipper-1.8.0-jumbo-1.tar.gz 32533148 BLAKE2B 15929fa25314438619899582b209bee6902b1e53dc2df39ed6a686820665fd4d8e56d26b3f0082d05dc6be2f54add3526570d936c0a929641e33e6dcfb7a13b5 SHA512 8b7fad7a6330b5ff1afc306218ba698aaa27776b566f82c2e76102d5ceb10aeafa69d71fa6fff67c81996ea2c6a04384bab4696ed192306c6d074873562e7089
+DIST john-1.9.0-jumbo-1.tar.xz 33638768 BLAKE2B 2fd6813e234308408d42581705ee8b25f9217a3dfb43f05483156f7bb67d0ce0d6de9c3ce8c2e4a17bb99bb377119dae2897bc08c800e7bc80bc6cf245400df6 SHA512 c5cb5dc739ee4c666f8479cdf10511fddc391b590c59f90c060d3ccd8449b794ac7b831a6d1f7553883892499e709a66578cfa4d62caef9b7e0a831eb827e808
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild
new file mode 100644 (file)
index 0000000..40128aa
--- /dev/null
@@ -0,0 +1,123 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs pax-utils
+
+DESCRIPTION="fast password cracker"
+HOMEPAGE="http://www.openwall.com/john/"
+
+MY_PN="JohnTheRipper"
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
+       inherit git-r3
+       KEYWORDS=""
+else
+       JUMBO="jumbo-1"
+       MY_PV="${PV}-${JUMBO}"
+       MY_P="john-${MY_PV}"
+       SRC_URI="https://www.openwall.com/john/k/${MY_P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+       S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+#removed rexgen and commoncrypto
+IUSE="custom-cflags kerberos mpi opencl openmp pcap"
+
+DEPEND=">=dev-libs/openssl-1.0.1:0
+       mpi? ( virtual/mpi )
+       opencl? ( virtual/opencl )
+       kerberos? ( virtual/krb5 )
+       pcap? ( net-libs/libpcap )
+       dev-libs/gmp:*
+       sys-libs/zlib
+       app-arch/bzip2"
+
+RDEPEND="${DEPEND}
+               !app-crypt/johntheripper"
+
+pkg_setup() {
+       if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
+               tc-has-openmp || die "Please switch to an openmp compatible compiler"
+       fi
+}
+
+src_prepare() {
+       sed -i 's#$prefix/share/john#/etc/john#' src/configure || die
+       default
+}
+
+src_configure() {
+       cd src || die
+
+       use custom-cflags || strip-flags
+
+       econf \
+               --disable-native-march \
+               --disable-native-tests \
+               --without-commoncrypto \
+               --disable-rexgen \
+               --with-openssl \
+               --with-systemwide \
+               $(use_enable mpi) \
+               $(use_enable opencl) \
+               $(use_enable openmp) \
+               $(use_enable pcap)
+}
+
+src_compile() {
+       emake -C src
+}
+
+src_test() {
+       pax-mark -mr run/john
+       #if use opencl; then
+               #gpu tests fail in portage, so run cpu only tests
+       #       ./run/john --device=cpu --test=0 --verbosity=2 || die
+       #else
+               #weak tests
+       #       ./run/john --test=0 --verbosity=2 || die
+               #strong tests
+               #./run/john --test=1 --verbosity=2 || die
+       #fi
+       ewarn "When built systemwide, john can't run tests without reading files in /etc."
+       ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
+}
+
+src_install() {
+       # executables
+       dosbin run/john
+       newsbin run/mailer john-mailer
+
+       pax-mark -mr "${ED}/usr/sbin/john"
+
+       # grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
+       for s in \
+               unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
+               zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
+               hccap2john base64conv truecrypt_volume2john keystore2john
+       do
+               dosym john /usr/sbin/$s
+       done
+
+       insinto /usr/share/john
+       doins run/*.py
+
+       if use opencl; then
+               insinto /etc/john
+               doins -r run/kernels
+       fi
+
+       # config files
+       insinto /etc/john
+       doins run/*.chr run/password.lst
+       doins run/*.conf
+       doins -r run/rules run/ztex
+
+       # documentation
+       dodoc -r doc/*
+}