version bump of 0.11 snapshot
authorPrzemyslaw Maciag <troll@gentoo.org>
Thu, 1 Feb 2007 23:20:56 +0000 (23:20 +0000)
committerPrzemyslaw Maciag <troll@gentoo.org>
Thu, 1 Feb 2007 23:20:56 +0000 (23:20 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-im/psi/ChangeLog
net-im/psi/files/digest-psi-0.11_pre20070201 [new file with mode: 0644]
net-im/psi/files/psi-ptr_64bit_fix.patch [new file with mode: 0644]
net-im/psi/psi-0.11_pre20070201.ebuild [new file with mode: 0644]

index ea138ea6ee95fe8baf5ad173e7c1e1ace083167e..d5033fb4f7408612785f14ba8f24b381086c77f8 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-im/psi
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.109 2007/01/01 23:50:31 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.110 2007/02/01 23:20:56 troll Exp $
+
+*psi-0.11_pre20070201 (01 Feb 2007)
+
+  01 Feb 2007; Przemysław Maciąg <troll@gentoo.org>
+  +files/psi-ptr_64bit_fix.patch, -psi-0.11_pre20061231.ebuild,
+  +psi-0.11_pre20070201.ebuild:
+  Version bump of 0.11 snapshot with ebuild cleanups and amd64 plugin fix
 
   01 Jan 2007; Przemysław Maciąg <troll@gentoo.org>
   psi-0.11_pre20061231.ebuild:
diff --git a/net-im/psi/files/digest-psi-0.11_pre20070201 b/net-im/psi/files/digest-psi-0.11_pre20070201
new file mode 100644 (file)
index 0000000..0fbc6e1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 77351e831d56cd5de8eb8b9091d7b02b psi-dev-snapshot-2007-02-01.tar.bz2 2367209
+RMD160 28ccef3760eba2ec75565672fba0135d05c60416 psi-dev-snapshot-2007-02-01.tar.bz2 2367209
+SHA256 c2dee74474b8744230d9596cf80365ad22aefeb4b9d317a2ab7281224d94f91f psi-dev-snapshot-2007-02-01.tar.bz2 2367209
diff --git a/net-im/psi/files/psi-ptr_64bit_fix.patch b/net-im/psi/files/psi-ptr_64bit_fix.patch
new file mode 100644 (file)
index 0000000..ab428fc
--- /dev/null
@@ -0,0 +1,11 @@
+diff -Naur psi-dev-snapshot-2007-01-12-orig/src/pluginmanager.cpp psi-dev-snapshot-2007-01-12/src/pluginmanager.cpp
+--- psi-dev-snapshot-2007-01-12-orig/src/pluginmanager.cpp     2007-01-12 06:30:08.000000000 +0100
++++ psi-dev-snapshot-2007-01-12/src/pluginmanager.cpp  2007-01-13 01:54:03.000000000 +0100
+@@ -422,7 +422,6 @@
+  */ 
+ void PluginManager::sendStanza( const PsiAccount* account, const QString& stanza)
+ {
+-      qDebug(qPrintable(QString("Want to send stanza  to account %2").arg((int)account)));
+       if (!clients_.contains(account) || !verifyStanza(stanza))
+               return;
+       clients_[account]->send(stanza);
diff --git a/net-im/psi/psi-0.11_pre20070201.ebuild b/net-im/psi/psi-0.11_pre20070201.ebuild
new file mode 100644 (file)
index 0000000..0eb365d
--- /dev/null
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.11_pre20070201.ebuild,v 1.1 2007/02/01 23:20:56 troll Exp $
+
+inherit confutils eutils qt4
+
+MY_PV="${PV:8:4}-${PV:12:2}-${PV:14:2}"
+MY_P="${PN}-dev-snapshot-${MY_PV}"
+
+IUSE="doc jingle plugins sasl spell ssl xscreensaver"
+
+DESCRIPTION="QT 4.x Jabber Client, with Licq-like interface"
+HOMEPAGE="http://psi-im.org/"
+SRC_URI="http://psi-im.org/files/snapshot/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="$(qt4_min_version 4.2)
+       media-libs/libpng
+       sys-libs/zlib
+       dev-libs/glib
+       doc? ( app-doc/doxygen )
+       jingle? ( ~net-libs/ortp-0.7.1
+               media-libs/speex )
+       sasl? ( dev-libs/cyrus-sasl )
+       spell? ( app-text/aspell )
+       ssl? ( dev-libs/openssl )
+       xscreensaver? ( x11-misc/xscreensaver )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       if ! (built_with_use x11-libs/qt qt3support); then
+               eerror "In order to compile psi with jingle support (google/talk"
+               eerror "xmpp extension) you will need to recompile qt4 with"
+               eerror "qt3support use flag enabled."
+               die "Recompile qt4 with qt3support use flag enabled"
+       fi;
+}
+
+src_unpack() {
+       unpack ${A}
+
+       cd ${S}
+       epatch ${FILESDIR}/psi-jingle-gcc4.patch
+       epatch ${FILESDIR}/psi-ptr_64bit_fix.patch
+}
+
+src_compile() {
+       # growl is mac osx extension only - maybe someday we will want this
+       local myconf="--disable-growl"
+
+       # jingle is still alpha code...
+       if use jingle; then
+               mv configure-jingle configure
+               chmod +x configure
+
+               myconf="${myconf}  --enable-jingle"
+       else
+               # xmms must die!
+               myconf="${myconf}  --disable-xmms"
+       fi;
+
+       QTDIR=/usr/lib ./configure \
+               --prefix=/usr \
+               $(enable_extension_disable xss xscreensaver) \
+               $(enable_extension_disable cyrussasl sasl) \
+               $(enable_extension_disable aspell spell) \
+               $(enable_extension_disable openssl ssl) \
+               $(use_enable plugins) \
+               ${myconf} || die "configure failed"
+
+       # for custom CXXFLAGS - should use eqmake in near future
+       cd ${S}/src
+       qmake src.pro \
+               QTDIR=/usr/lib \
+               QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+               QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+               QMAKE=/usr/bin/qmake \
+               QMAKE_RPATH= \
+               "CONFIG+=no_fixpath release" \
+               || die "qmake failed"
+
+       cd ${S}
+       qmake psi.pro \
+               QTDIR=/usr/lib \
+               QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+               QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+               QMAKE=/usr/bin/qmake \
+               QMAKE_RPATH= \
+               "CONFIG+=no_fixpath release" \
+               || die "qmake failed"
+
+       # for now, we need bundled qca :/
+       cd ${S}/third-party/qca
+       qmake qca.pro \
+               QTDIR=/usr/lib \
+               QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+               QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+               QMAKE=/usr/bin/qmake \
+               QMAKE_RPATH= \
+               "CONFIG+=no_fixpath release" \
+               || die "qmake failed"
+
+       cd ${S}
+       emake || die "make failed"
+
+       if use doc; then
+               cd ${S}/doc
+               make api_public
+       fi;
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install || die "emake install failed"
+
+       #this way the docs will also be installed in the standard gentoo dir
+       for i in roster system; do
+               newdoc ${S}/iconsets/${i}/README README.${i}
+       done;
+       newdoc certs/README README.certs
+       dodoc ChangeLog README TODO
+
+       use doc && cp -ar ${S}/doc/api ${D}/usr/share/psi
+}