sys-libs/libcxx: drop invalid gcc-version check, bug #705282
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 5 May 2020 21:40:03 +0000 (22:40 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 5 May 2020 21:40:17 +0000 (22:40 +0100)
gcc-4.7 is very old version. The version check uses lexicographical
compare. It should use version compare to be valid. Let's just drop
the check.

Closes: https://bugs.gentoo.org/705282
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
sys-libs/libcxx/libcxx-10.0.0.ebuild
sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
sys-libs/libcxx/libcxx-8.0.1.ebuild
sys-libs/libcxx/libcxx-9.0.1.ebuild

index 5a3729e82ad3a387866de6435de8246b89ebcbe9..6e1bba971a9b7b959512a0a8eace1d8774d1fa83 100644 (file)
@@ -56,12 +56,6 @@ pkg_setup() {
                eerror "and try again."
                die
        fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
 }
 
 test_compiler() {
index 24c015cc1bc54ce440acf1fb7edb1f6ee717b066..20a1d2faae6278e3fb780c2b8c4c894838ab12e2 100644 (file)
@@ -56,12 +56,6 @@ pkg_setup() {
                eerror "and try again."
                die
        fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
 }
 
 test_compiler() {
index 7e8f34b8c137bfe5cbec52b34a452940639934ea..c8f3b48d30c5d9ac285680291bba34f38bd3a25e 100644 (file)
@@ -57,12 +57,6 @@ pkg_setup() {
                eerror "and try again."
                die
        fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
 }
 
 test_compiler() {
index d126d9a2b01314ffc71101a9993f9d68d9579d6f..f1ddc2f89dd047a968c34011242a3fbc72c34017 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -66,12 +66,6 @@ pkg_setup() {
                eerror "and try again."
                die
        fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
 }
 
 test_compiler() {
index e5a479380d9dc787e170a184dcae36898f17866e..c144def9c7929da98793d623bd49e23fd160014e 100644 (file)
@@ -58,12 +58,6 @@ pkg_setup() {
                eerror "and try again."
                die
        fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
 }
 
 test_compiler() {