projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cfe5e7b
)
s/OSError/EnvironmentError/ since shutil.move() generally raises an IOError.
author
Zac Medico
<zmedico@gentoo.org>
Sat, 23 Jun 2007 11:09:45 +0000
(11:09 -0000)
committer
Zac Medico
<zmedico@gentoo.org>
Sat, 23 Jun 2007 11:09:45 +0000
(11:09 -0000)
svn path=/main/trunk/; revision=6969
pym/portage/dbapi/vartree.py
patch
|
blob
|
history
diff --git
a/pym/portage/dbapi/vartree.py
b/pym/portage/dbapi/vartree.py
index c52fcb3b36af419342dda6cd7f54f7ba31c78f02..b15cede57366afd37318a4b7e3bf877c2004b075 100644
(file)
--- a/
pym/portage/dbapi/vartree.py
+++ b/
pym/portage/dbapi/vartree.py
@@
-310,7
+310,7
@@
class vardbapi(dbapi):
try:
shutil.move(os.path.join(newpath, old_pf + ".ebuild"),
os.path.join(newpath, new_pf + ".ebuild"))
- except
OS
Error, e:
+ except
Environment
Error, e:
if e.errno != errno.ENOENT:
raise
del e