net-libs/nghttp2: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 6 Apr 2020 09:04:12 +0000 (11:04 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 6 Apr 2020 09:04:23 +0000 (11:04 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/nghttp2/Manifest
net-libs/nghttp2/nghttp2-1.39.2.ebuild [deleted file]

index de6cf3d0ad63b4a7c9a052524575e08bc1a6ab97..54a08ac5870746ad67d7fc7517589fddcd6abd7c 100644 (file)
@@ -1,2 +1 @@
-DIST nghttp2-1.39.2.tar.xz 1635428 BLAKE2B 4569774c33f17d51ac889c385697fcead82106db421399ceb22ad2aafabe64a576445d9272adcf37e2fec47cdd6ac1dc6423efd49012ca7be0aa2087609a0397 SHA512 d8c971543e3e87736dfafebca55e9ecd0644e304c9731edaccba34170205824476595861a439077289b438ad489dd6008dedf2c6b2c111920300329be1b1bf34
 DIST nghttp2-1.40.0.tar.xz 1637004 BLAKE2B 7735ba06cd0655450a6379ea33cc79e557f73b5b4b2ba746564a53e6c305aa656b62da7c3b00dbb70472dffc471271f73af0bcbfadab99406d217d1989ad052a SHA512 3f9b989c4bd9571b11bb9d59fe2dfd5596ba3962babfc836587d5047e780400a6cf46e43c602caa25ca83c03b84a1629953140d45223099b193df54a719745ce
diff --git a/net-libs/nghttp2/nghttp2-1.39.2.ebuild b/net-libs/nghttp2/nghttp2-1.39.2.ebuild
deleted file mode 100644 (file)
index c0d775b..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: Add python support.
-
-EAPI=7
-
-inherit multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
-       EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
-       inherit autotools git-r3
-else
-       SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
-       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-fi
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
-
-RESTRICT="!test? ( test )"
-
-SSL_DEPEND="
-       !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
-       libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
-"
-RDEPEND="
-       cxx? (
-               ${SSL_DEPEND}
-               dev-libs/boost:=[${MULTILIB_USEDEP},threads]
-       )
-       hpack-tools? ( >=dev-libs/jansson-2.5 )
-       jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
-       utils? (
-               ${SSL_DEPEND}
-               >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
-               >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
-               net-dns/c-ares:=[${MULTILIB_USEDEP}]
-       )
-       xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-
-src_prepare() {
-       default
-       [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               --disable-examples
-               --disable-failmalloc
-               --disable-python-bindings
-               --disable-werror
-               --without-cython
-               $(use_enable cxx asio-lib)
-               $(use_enable debug)
-               $(multilib_native_use_enable hpack-tools)
-               $(use_enable static-libs static)
-               $(use_enable threads)
-               $(multilib_native_use_enable utils app)
-               $(multilib_native_use_with jemalloc)
-               $(multilib_native_use_with xml libxml2)
-       )
-       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
-       if ! use static-libs ; then
-               find "${ED}"/usr -name '*.la' -delete || die
-       fi
-}