www-servers/tornado: Use virtual for module with mixed support
authorJustin Lecher <jlec@gentoo.org>
Tue, 10 Nov 2015 11:16:09 +0000 (12:16 +0100)
committerJustin Lecher <jlec@gentoo.org>
Tue, 10 Nov 2015 11:49:39 +0000 (12:49 +0100)
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <jlec@gentoo.org>
www-servers/tornado/tornado-4.2.1.ebuild

index c3808d8dbf0b03574e821cbd85956832b87d0467..7cbfbc254f5276d441cf830e9e8ef0c30825b6f5 100644 (file)
@@ -18,14 +18,15 @@ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc examples test"
 
 CDEPEND="
+       dev-python/certifi[${PYTHON_USEDEP}]
        >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/asyncio[${PYTHON_USEDEP}]' 'python3_3')
+       $(python_gen_cond_dep 'virtual/python-asyncio[${PYTHON_USEDEP}]' 'python3*')
        $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2_7')
-       $(python_gen_cond_dep 'dev-python/certifi[${PYTHON_USEDEP}]' 'python2_7' 'python3_3')
-       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7 pypy')
        $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
        $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
-       virtual/python-singledispatch
+       virtual/python-backports_abc[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       virtual/python-singledispatch[${PYTHON_USEDEP}]
 "
 # dev-python/twisted-* only supports python2_7 currently
 DEPEND="