dev-python/kid: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:31 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:31 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/kid/kid-0.9.6-r1.ebuild

index 6a1ce66efaae10d635f69ef4bb6f755ea69f52d5..49769fe161559e0a7cc8b57345b1987d9bb5b7ad 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -34,7 +34,10 @@ python_install_all() {
 #      dobin bin/*
 
        use doc && local HTML_DOCS=( doc/html/. )
-       use examples && local EXAMPLES=( examples/. )
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }