dev-python/pyproj: Fix the fix
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 14:35:40 +0000 (15:35 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 14:37:35 +0000 (15:37 +0100)
Closes: https://bugs.gentoo.org/702218
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pyproj/pyproj-2.4.1.ebuild

index 4caf7eaf13530788155217899fbbeb1fdadcebc1..52b61f2b5316d969448e3de2f657337235c97ae2 100644 (file)
@@ -31,7 +31,8 @@ BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 distutils_enable_tests pytest
 
 python_check_deps() {
-       use doc && has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+       use doc || return 0
+       has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
 python_prepare_all() {