dev-libs/libsigc++: bump to 2.20.1
authorMart Raudsepp <leio@gentoo.org>
Wed, 31 Oct 2018 13:16:27 +0000 (15:16 +0200)
committerMart Raudsepp <leio@gentoo.org>
Wed, 31 Oct 2018 13:16:47 +0000 (15:16 +0200)
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

dev-libs/libsigc++/Manifest
dev-libs/libsigc++/libsigc++-2.10.1.ebuild [new file with mode: 0644]

index bbc5954d998844a5fcb5f9deae920da40f477f29..023cf505a273c9cc33c64e3fb4fdc987908993e4 100644 (file)
@@ -1,2 +1,3 @@
 DIST libsigc++-1.2.7.tar.bz2 326205 BLAKE2B b316460178224c0b8177ce9a236c69a8b737bf7356b290b59eaeb60b09285c61d113bfc7de89bd712c3c049a492f5cc36d205ac77816aff73e587e8a42ade520 SHA512 79fd9657219459bce64fc069dbcb054959e324b5d546b5f11acaae5e5bedcc4dca699a21c949e3f6b2ec0dbe1c3dba3981158e5950d0aaba5028445b2ad5740f
 DIST libsigc++-2.10.0.tar.xz 3794612 BLAKE2B 205cd8cedbe25d04108df888c392fe6a14829826cf1b6b7604a03f357788dfa83a5ba213d6365c48965dd16fcd7b545c9e76d4e4d10971cc1c9ccb172ec0400f SHA512 5b96df21d6bd6ba41520c7219e77695a86aabc60b7259262c7a9f4b8475ce0e2fd8dc37bcf7c17e24e818ff28c262d682b964c83e215b51bdbe000f3f58794ae
+DIST libsigc++-2.10.1.tar.xz 4062388 BLAKE2B 3bd988acae78b7d463c966fa5c8da68b35d8a0b0bf4762811b7a9fdf82357b29aaa48d64e19f4cb6bd0f42ee70ad77a64a4905d1ad609dbe11ca8ff7596527c6 SHA512 e2bd7b1a97019be010dee1594271bbf7cae92b28e31dcb3c6d7d60643a0996233f0a75a9337b4afcb5b7dc453bfc3159d82f6daacfbcd8993a39ccecaf811bb2
diff --git a/dev-libs/libsigc++/libsigc++-2.10.1.ebuild b/dev-libs/libsigc++/libsigc++-2.10.1.ebuild
new file mode 100644 (file)
index 0000000..8bb4081
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 flag-o-matic multilib-minimal
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="sys-devel/m4
+       doc? ( app-doc/doxygen )
+       test? ( dev-libs/boost[${MULTILIB_USEDEP}] )"
+# Needs mm-common for eautoreconf
+
+src_prepare() {
+       # don't waste time building examples
+       sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
+               Makefile.am Makefile.in || die "sed examples failed"
+
+       # don't waste time building tests unless USE=test
+       if ! use test ; then
+               sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
+                       Makefile.am Makefile.in || die "sed tests failed"
+       fi
+
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       filter-flags -fno-exceptions #84263
+
+       ECONF_SOURCE="${S}" gnome2_src_configure \
+               $(multilib_native_use_enable doc documentation) \
+               $(use_enable static-libs static) \
+               $(use_enable test benchmark)
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       # Note: html docs are installed into /usr/share/doc/libsigc++-2.0
+       # We can't use /usr/share/doc/${PF} because of links from glibmm etc. docs
+       use doc && dodoc -r examples
+}