sci-libs/med: Switch to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Jan 2020 18:59:51 +0000 (19:59 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Jan 2020 18:59:51 +0000 (19:59 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/med/med-4.0.0-r2.ebuild

index 7f05bac5c3a4c0e22ea1ab40135b8b569bd858a3..2e060a824c7fc930b9472f668efb57f28b2aac2c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -13,7 +13,7 @@ FORTRAN_NEEDED=fortran
 # complicated for the build system
 PYTHON_COMPAT=( python3_{5,6,7} )
 
-inherit cmake-utils fortran-2 python-single-r1
+inherit cmake fortran-2 python-single-r1
 
 DESCRIPTION="A library to store and exchange meshed data or computation results"
 HOMEPAGE="https://www.salome-platform.org/user-section/about/med"
@@ -68,7 +68,7 @@ src_prepare() {
                        "${cm}" || die "sed on ${cm} failed"
        done
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -85,11 +85,11 @@ src_configure() {
                -DMEDFILE_INSTALL_DOC=$(usex doc)
                -DMEDFILE_USE_MPI=$(usex mpi)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        # we don't need old 2.3.6 include files
        rm -r "${ED}"/usr/include/2.3.6 || die "failed to delete obsolete include dir"
@@ -113,5 +113,5 @@ src_install() {
 src_test() {
        # override parallel mode only for tests
        local myctestargs=( "-j 1" )
-       cmake-utils_src_test
+       cmake_src_test
 }