app-benchmarks/i7z: Enforce -fcommon
authorPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 18:33:01 +0000 (19:33 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 18:44:10 +0000 (19:44 +0100)
Closes: https://bugs.gentoo.org/706690
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild

index d121c8ebe66cd3db13c5fd52a55b3f2f1cee3209..47b4c7b42eccca358f1ba4442bc4726c638e6024 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 inherit flag-o-matic qmake-utils toolchain-funcs
 
 COMMIT="5023138d7c35c4667c938b853e5ea89737334e92"
@@ -22,6 +22,7 @@ RDEPEND="
        )
 "
 DEPEND="${RDEPEND}"
+BDEPEND=""
 
 PATCHES=(
        "${FILESDIR}"/i7z-0.27.2-ncurses.patch
@@ -40,6 +41,9 @@ PATCHES=(
 S="${WORKDIR}/${PN}-${COMMIT}"
 
 src_configure() {
+       # Workaround to build with gcc-10 until I find a patch
+       append-cflags -fcommon
+
        tc-export CC PKG_CONFIG
        cd GUI || die
        use qt5 && eqmake5 ${PN}_GUI.pro