dev-python/pytest-expect: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:06:26 +0000 (18:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:23:33 +0000 (18:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild

index 5148896cb8e6db3715afc1b0f9b35afaa62fa9d3..ef30899cfd960b5d6036a1002ebd279dd4238a96 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
 
 inherit distutils-r1
 
@@ -19,9 +19,5 @@ RDEPEND="
        dev-python/pytest[${PYTHON_USEDEP}]
        dev-python/u-msgpack[${PYTHON_USEDEP}]"
 
-BDEPEND="
-       ${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
 # no tests...
 RESTRICT="test"