app-admin/puppet-agent: 6.8.0 stable amd64 and x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 23 Sep 2019 15:30:21 +0000 (10:30 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 23 Sep 2019 15:30:21 +0000 (10:30 -0500)
Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-6.6.0.ebuild [deleted file]
app-admin/puppet-agent/puppet-agent-6.8.0.ebuild

index e6c6f0a2fdca0653e2f353e5b59f7410e610777e..ee5edccb7eabd15a739c0f5b4d056b19bd5afcf0 100644 (file)
@@ -1,5 +1,3 @@
-DIST puppet-agent_6.6.0-1stretch_amd64.deb 19177382 BLAKE2B c8034e4a943394da7fd97756b3dfb59897f3d787a8f49743a4c42ed47db4411f6d0e125cf6984728a108e5070cc8e42ca0a203d2afdcce99e08ae38a6ebb9293 SHA512 f0d129b357feb6e5d05c080437910e119bbce0e97e36927c2f97d3d7fb8f54a0eb1503a74ffec3cef7fd29785fe97ffd53f04a4be6a35b558ee278af8871289b
-DIST puppet-agent_6.6.0-1stretch_i386.deb 19443284 BLAKE2B c017abc3166b3cb04a98c511b5ab05dd7076906a38edd8ee919848c130ae5b1cb6c7542b6c6c3da267fa801e152ad963c84293083c709dd769185f943a4bebcb SHA512 adadc3201dae261f2000282b67b8c4735eeb588c4c6c5dcbcde2e655772bebb1c343611607d84ba1b019279480445dc44cd4e3cc3d64e89b70e93b85a37678d5
 DIST puppet-agent_6.7.2-1stretch_amd64.deb 19184682 BLAKE2B 6078c1b21f0e737881d949cfaf052571b40df450e53724696e2738141da30e59da7abf03ce00285ab77fd4ac52291ab6e42da373420807499f37b75c872fa83e SHA512 1c464448b1478397af7b806f8bfcaee0378af9d4b6bfa5a73e8245064329b1b49136107c5fcbaea0ef6cd4e1daf840d1ba331e798b2cd255ead54969520315c9
 DIST puppet-agent_6.7.2-1stretch_i386.deb 19452604 BLAKE2B 1915e7b7085db6cb87980a98a7cb85881331719e2af98b07f8461514a0296b3cf5181eb88f78893055a0fa09fc2ffce0e81e866db27abcecf9d8f745e329311c SHA512 8d89735601c9764e207eef77f5d42e836ee9d7c0c0f2856e0f293919cce52e7a42fc28fca42bd0e0bed760063aae527007ef7ce25503ce05fcfd495a44243ee3
 DIST puppet-agent_6.8.0-1stretch_amd64.deb 19184708 BLAKE2B ac961857784eaaa55604285cf305dac437007628ea5baa3c3ae9a8a345fcb8cf2b20820bd80cc2c96afb77cb03c4d2779b17b1183c9bc9461b56860d2179f448 SHA512 707146f71b21df4b89244df7b786f481136cfe7b0cabf20aa0d4784aca547ba85c75d13309b77c853b9e034b8271f350b30bc5358010d90b7573e3fdb63c31b6
diff --git a/app-admin/puppet-agent/puppet-agent-6.6.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.6.0.ebuild
deleted file mode 100644 (file)
index c648209..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit eutils systemd unpacker user
-
-DESCRIPTION="general puppet client utils along with hiera and facter"
-HOMEPAGE="https://puppetlabs.com/"
-SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
-SRC_URI="
-       amd64? ( ${SRC_BASE}_amd64.deb )
-       x86?   ( ${SRC_BASE}_i386.deb )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="puppetdb selinux"
-RESTRICT="strip"
-
-CDEPEND="!app-admin/augeas
-       !app-admin/puppet
-       !dev-ruby/hiera
-       !dev-ruby/facter
-       !app-emulation/virt-what"
-
-DEPEND="
-       ${CDEPEND}"
-RDEPEND="${CDEPEND}
-       app-portage/eix
-       sys-apps/dmidecode
-       sys-libs/glibc
-       sys-libs/readline:0/7
-       sys-libs/ncurses:0[tinfo]
-       selinux? (
-               sys-libs/libselinux[ruby]
-               sec-policy/selinux-puppet
-       )
-       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup puppet
-       enewuser puppet -1 -1 /var/run/puppet puppet
-}
-
-src_install() {
-       # conf.d
-       doconfd etc/default/puppet
-       doconfd etc/default/pxp-agent
-       # logrotate.d
-       insinto /etc/logrotate.d
-       doins etc/logrotate.d/pxp-agent
-       # puppet itself
-       insinto /etc/puppetlabs
-       doins -r etc/puppetlabs/*
-       # logdir for systemd
-       dodir var/log/puppetlabs/puppet/
-       fperms 0750 var/log/puppetlabs/puppet/
-       # the rest
-       insinto /opt
-       dodir opt/puppetlabs/puppet/cache
-       doins -r opt/*
-       fperms 0750 /opt/puppetlabs/puppet/cache
-       # init
-       newinitd "${FILESDIR}/puppet.initd" puppet
-       systemd_dounit lib/systemd/system/puppet.service
-       systemd_dounit lib/systemd/system/pxp-agent.service
-       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
-       # symlinks
-       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
-       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
-       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
-       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
-       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
-       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
-       dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
-       dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
-}
index a72df734d6b1b21733754723bc01e47b1e426792..c648209a4a7e85f4e52398f06574ad8d2e769942 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="puppetdb selinux"
 RESTRICT="strip"