virtual/libudev: revbump with proper static-libs usedep
authorMike Gilbert <floppym@gentoo.org>
Mon, 28 Oct 2019 17:10:00 +0000 (13:10 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 28 Oct 2019 17:10:00 +0000 (13:10 -0400)
Package-Manager: Portage-2.3.78_p4, Repoman-2.3.17_p100
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
virtual/libudev/libudev-232-r3.ebuild [new file with mode: 0644]

diff --git a/virtual/libudev/libudev-232-r3.ebuild b/virtual/libudev/libudev-232-r3.ebuild
new file mode 100644 (file)
index 0000000..cda316a
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-build
+
+DESCRIPTION="Virtual for libudev providers"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs systemd"
+
+RDEPEND="
+       !systemd? ( || (
+               >=sys-fs/eudev-3.2.9:0/0[${MULTILIB_USEDEP},static-libs(-)?]
+               >=sys-fs/udev-232:0/0[${MULTILIB_USEDEP},static-libs(-)?]
+       ) )
+       systemd? ( >=sys-apps/systemd-232:0/2[${MULTILIB_USEDEP},static-libs(-)?] )
+"