app-editors/kakoune: bump to 2020-01-16 release
authorJoonas Niilola <juippis@gentoo.org>
Mon, 25 May 2020 13:06:58 +0000 (16:06 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 25 May 2020 13:06:58 +0000 (16:06 +0300)
Closes: https://bugs.gentoo.org/674642
Closes: https://bugs.gentoo.org/722038
Closes: https://bugs.gentoo.org/723514
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-editors/kakoune/Manifest
app-editors/kakoune/files/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch [new file with mode: 0644]
app-editors/kakoune/kakoune-2020.01.16.ebuild [new file with mode: 0644]

index 22738c776b972b0ed69d2962aaa6a241c785d985..aa2eb431cddb6fdb06e831713555bd902b65f613 100644 (file)
@@ -1 +1,2 @@
 DIST kakoune-0_pre20171120.tar.gz 460659 BLAKE2B 443583e5d766b227f678f9adec76f06a0dfe6a29e2d6f38896b20a911e08e933e1e631d1018e1510a49fbb71b4b0258029fd33ece8c478bd228ef67b6fae939a SHA512 0208fd932dcf6cef3fac3338dfc15f0ba36ed4e3fa282cc5ffac5ad823f91b553a8c34747ff33ec4382257a1eb71f21181b63595031f9f237cba3bc8eeda3626
+DIST kakoune-2020.01.16.tar.gz 579837 BLAKE2B 46abfd7f2bf2db6f9755a5b4f547e63e72ac7eef46ad0903dac08d0f422774632ac5aa3dc1e6c69aa6f0527bdff0ea1792574933ceb35b2495927f747be94aaf SHA512 81a0fb522fd7f289ede36f966e815d03550df389b05d27fa430474dd55a90cc0e1c5231e660328040f3bd79d155d37b7b135b52b93cee536c15d13fc9d06baa0
diff --git a/app-editors/kakoune/files/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch b/app-editors/kakoune/files/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch
new file mode 100644 (file)
index 0000000..726968e
--- /dev/null
@@ -0,0 +1,15 @@
+diff -Naur a/rc/filetype/sh.kak b/rc/filetype/sh.kak
+--- a/rc/filetype/sh.kak       2020-01-16 11:52:20.000000000 +0200
++++ b/rc/filetype/sh.kak       2020-05-25 15:50:20.417809942 +0300
+@@ -2,6 +2,11 @@
+     set-option buffer filetype sh
+ }
++hook global BufCreate .*\.ebuild %{
++    set-option buffer filetype sh
++}
++
++
+ hook global WinSetOption filetype=sh %{
+     require-module sh
+     set-option window static_words %opt{sh_static_words}
diff --git a/app-editors/kakoune/kakoune-2020.01.16.ebuild b/app-editors/kakoune/kakoune-2020.01.16.ebuild
new file mode 100644 (file)
index 0000000..476bbd2
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch )
+
+src_configure() { :; }
+
+src_compile() {
+       cd src/ || die
+
+       emake static=$(usex static-libs yes no) all
+}
+
+src_test() {
+       cd src/ || die
+       emake test
+}
+
+src_install() {
+       emake PREFIX="${D}"/usr docdir="${D}/usr/share/doc/${PF}" install
+
+       rm "${D}/usr/share/man/man1/kak.1.gz" || die
+       doman doc/kak.1
+}