media-libs/libdc1394: EAPI 6 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 18 Feb 2018 22:34:25 +0000 (23:34 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 19 Feb 2018 10:17:04 +0000 (11:17 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

media-libs/libdc1394/files/libdc1394-2.2.1-pthread.patch
media-libs/libdc1394/libdc1394-2.2.5-r1.ebuild [new file with mode: 0644]

index 6ea7651e146388ef0217638cbf8558f63f8ffc4e..535dc9040d8ef89d85cd26dbf3ed0b8064147167 100644 (file)
@@ -1,7 +1,7 @@
 http://bugs.gentoo.org/514008
 
---- dc1394/usb/Makefile.am
-+++ dc1394/usb/Makefile.am
+--- a/dc1394/usb/Makefile.am
++++ b/dc1394/usb/Makefile.am
 @@ -8,7 +8,7 @@
  endif
  
diff --git a/media-libs/libdc1394/libdc1394-2.2.5-r1.ebuild b/media-libs/libdc1394/libdc1394-2.2.5-r1.ebuild
new file mode 100644 (file)
index 0000000..1006141
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library to interface with IEEE 1394 cameras following the IIDC specification"
+HOMEPAGE="https://sourceforge.net/projects/libdc1394/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+       https://dev.gentoo.org/~ssuominen/sdl.m4-20140620.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs X"
+
+RDEPEND="
+       >=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]
+       >=virtual/libusb-1-r1:1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.1-pthread.patch )
+
+src_prepare() {
+       default
+       AT_M4DIR=${WORKDIR}/aclocal eautoreconf
+}
+
+multilib_src_configure() {
+       local myconf="$(use_enable doc doxygen-html)"
+       multilib_is_native_abi || myconf="--disable-doxygen-html --disable-examples"
+
+       # X is only useful for examples that are not installed.
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable static-libs static) \
+               --program-suffix=2 \
+               --without-x \
+               ${myconf}
+}
+
+multilib_src_compile() {
+       default
+       multilib_is_native_abi && use doc && emake doc
+}
+
+multilib_src_install() {
+       multilib_is_native_abi && use doc && local HTML_DOCS=( doc/html/. )
+       default
+       find "${ED}" -name '*.la' -delete || die
+}