app-emulation/diskimage-builder: 2.23.0 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 7 Jun 2019 15:40:15 +0000 (10:40 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 7 Jun 2019 15:58:45 +0000 (10:58 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.14
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild [deleted file]
app-emulation/diskimage-builder/diskimage-builder-2.22.0.ebuild [deleted file]
app-emulation/diskimage-builder/diskimage-builder-2.23.0.ebuild

index 40e975e034099b5974e6d0601d99edd26f36fc71..5b6a35c2f2d2c0754cea8990998689a85f9a0b7e 100644 (file)
@@ -1,3 +1 @@
-DIST diskimage-builder-2.21.0.tar.gz 409367 BLAKE2B 25c8a819be8674eee38a97e822151527dd77d3f5e85016ebc1a7fa5bf907f64bdac47012eb748b69273b519580c6ea4ca845abd7800ddb4e3f60dd81da546a73 SHA512 51a871a772fd4ae35d0a8ea51f7c01502c374805f5de5ab37c2f18ea868a829c7085ecaa6a62690e8d6e85afe225cbab7ed86266eb5fc3e8741a8ff968cb35f9
-DIST diskimage-builder-2.22.0.tar.gz 410939 BLAKE2B ff5b3ce0f128001091e4621170def71cb6ef46cc278aee5a877caba0a3df054ac5e7027640a70ffdd8b8329764774ef801b0c0ad427babaec09a7123552edb50 SHA512 e051b668a86a4b386c2ec079a8f28bb5ab54ee6dbd1f39d7889075efa6abd4dff7063be24b817e05057f85036202f6193438df1a112009a1b954eaa4bb1b6e44
 DIST diskimage-builder-2.23.0.tar.gz 403817 BLAKE2B 14b67dc456bd9dab13a534f0f6df27b8a74514966ad965b401d33274d37ee2f201fa1dcd64b2c04a7503ab1f6a893dc40b5145c9559a7be74a029e2da226758a SHA512 89b2ee7eda56c610b9c343edd51276d54eb129ce319cf7f0fdebbccd1bba52903d16a71f1558bb76d2011d5267ffbc62bde94f5d7fd5aabdab2bc82abf10c685
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild
deleted file mode 100644 (file)
index 6e54043..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Golden Disk Image builder."
-HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
-       <dev-python/networkx-2.3[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
-       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
-       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
-       app-emulation/qemu
-       sys-block/parted
-       sys-fs/multipath-tools
-       sys-fs/dosfstools
-       sys-apps/gptfdisk
-       !dev-python/dib-utils[${PYTHON_USEDEP}]"
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.22.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.22.0.ebuild
deleted file mode 100644 (file)
index bda4c27..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Golden Disk Image builder."
-HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
-       <dev-python/networkx-2.3[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
-       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
-       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
-       app-emulation/qemu
-       sys-block/parted
-       sys-fs/multipath-tools
-       sys-fs/dosfstools
-       sys-apps/gptfdisk
-       !dev-python/dib-utils[${PYTHON_USEDEP}]"
index bda4c2798bb793b8b46636d97cc7069005829825..2d515286fbce137ae5ae74a3a7ae0bd898b43379 100644 (file)
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999* ]]; then
        EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
 else
        SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+       KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
 fi
 
 LICENSE="Apache-2.0"