sci-misc/boinc: New ebuild for boinc-7.6.33
authorSven Eden <yamakuzure@gmx.net>
Wed, 8 Jun 2016 14:35:37 +0000 (16:35 +0200)
committerDavid Seifert <soap@gentoo.org>
Tue, 14 Jun 2016 19:09:59 +0000 (21:09 +0200)
Package-Manager: portage-2.2.28
Closes: https://github.com/gentoo/gentoo/pull/1629

Signed-off-by: David Seifert <soap@gentoo.org>
sci-misc/boinc/Manifest
sci-misc/boinc/boinc-7.6.33.ebuild [new file with mode: 0644]

index 4f1d78df4fe7f09859676079ed0aeaaef788db90..1dc63ac67da45259d8fd20f684720277ebb06a9b 100644 (file)
@@ -1,3 +1,6 @@
 DIST boinc-7.2.42.tar.gz 45420832 SHA256 c4e9c6aef80db15afa3617804f6cdbf15586865d260b242a06197681a8ac86e6 SHA512 c702597b2469e40cdb1fe4d47ac7b808a2f5702d7199e8bc4f2e50ec7a1058057f4edc6baec9ff64b877da788a13bd74049348286c7cbc98a7f73232f25749d0 WHIRLPOOL ddade063072bef0a9dfcba50ce3878c8d0318e8ed607af045e7c7561296742dd66612d68d013be627692a3dbf54296b02dbc50533cd1d0d4a6b2deb53c99305e
+DIST boinc-7.2.44.tar.gz 46626134 SHA256 bae214f238b8b3d1826a44e3a9e5d91cbad165e7df6daf8a7f208f36c51c5425 SHA512 60f58eecbe1f8d1a272b338d0c2b2fcbfb95538c448cbfdab25d3e860129b519a2c3b2608a909e285bdf4378c23a71107a6d3c2d3aa519ec906480d81be19ca9 WHIRLPOOL f071fce088769ca35bacc9466e3a863bc619d025e14aa26b96a5a736027e4438a2d660df804d95cc635c4bd83e636c0c79e2712f2953bbc2fd905091ec1a1589
 DIST boinc-7.4.42.tar.gz 44075908 SHA256 2656727628cae8b15c39e48e08e0521aae345dd1cf4674c6730150500b30145f SHA512 6eabb130d38c55b551ce216afcb8b4a27d9755c4a20dfc30e7ab0c7e8ba5ab5af6995348ec5fee6b9711aa85f7fdbcef78b05894873d8780f20c9e29e17c8ad1 WHIRLPOOL 3b61de0a5a443d457ceda3c01bf824fa5d9a72c7e5d8e8da1bf35f1510a7d3fb72dbbf8ce329b2f8ca18c82afc16852df0cd047d4870b06537ddff473277d655
+DIST boinc-7.4.43.tar.gz 44144046 SHA256 f7b6c093e88227093cdc7c7a337eafe3d10ec4071bfe5cdc20dfa9fdd74fcb9b SHA512 3c9b95daa2083c61f7794482fb1a23e2eacd6f08da49e7378450bdffab15458c58405b2945cca24bd724018859b77474e220bef94dd78c7e42eb51f8789ede63 WHIRLPOOL 570d9fb837bcdf74985944894719aea4bdfff174da1d1b60592a895540e3d9d160759658a0fb452a51e796dc5f9111f3f9bd05e2a1e2a54d4fdefcf7847d3598
 DIST boinc-7.6.31.tar.gz 43534132 SHA256 133490409d4a8513024253dd22ccf6ab26f210226db97f2021fd75eb79a27f08 SHA512 b2f35e7446bf01f4557a0d3c18ccad49a3e71d72fd25d69ff2e023ac51b1293ce3a7066ca0959e35301d1d99fc66eabf11dd89845ac120326f27fcdfa30fcdeb WHIRLPOOL 0d5de909dbe8a7f961d221f01e2ffc57bacc72fc91ac26bdf30fff73f4ce80c1b60f5a7e782da8b8cda222a23455275fd96f18b902c77c971aa86a4c4a010641
+DIST boinc-7.6.33.tar.gz 43569544 SHA256 c4b1c29b9655013e0ac61dddf47ad7f30f38c46159f02a9d9dc8ab854e99aa6d SHA512 c1a98d1a489835abdac72b300c0c8ce82eec9a677ff891c57da4df9875a9bbdd4b45dd9d5ae6ddc2926a0e47ae281fb94ff87815b8aeab0786e15062465e2c20 WHIRLPOOL 118578c4058b3f19fab61982a2f2007379790f37cd077f80f7e4c6a7bed30016142c3236af6274553c19ac1a662b4022ddf6323e22c7dc697ea30ca0bccfbaeb
diff --git a/sci-misc/boinc/boinc-7.6.33.ebuild b/sci-misc/boinc/boinc-7.6.33.ebuild
new file mode 100644 (file)
index 0000000..3daf627
--- /dev/null
@@ -0,0 +1,154 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools flag-o-matic linux-info systemd user versionator wxwidgets
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X cuda curl_ssl_libressl +curl_ssl_openssl static-libs"
+
+REQUIRED_USE="^^ ( curl_ssl_libressl curl_ssl_openssl ) "
+
+# libcurl must not be using an ssl backend boinc does not support.
+# If the libcurl ssl backend changes, boinc should be recompiled.
+RDEPEND="
+       !sci-misc/boinc-bin
+       !app-admin/quickswitch
+       >=app-misc/ca-certificates-20080809
+       net-misc/curl[-curl_ssl_gnutls(-),curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+       sys-apps/util-linux
+       sys-libs/zlib
+       cuda? (
+               >=dev-util/nvidia-cuda-toolkit-2.1
+               >=x11-drivers/nvidia-drivers-180.22
+       )
+       X? (
+               dev-db/sqlite:3
+               media-libs/freeglut
+               sys-libs/glibc:2.2
+               virtual/jpeg:0=
+               x11-libs/gtk+:2
+               >=x11-libs/libnotify-0.7
+               x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
+       )
+"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       app-text/docbook-xml-dtd:4.4
+       app-text/docbook2X
+"
+
+S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
+
+pkg_setup() {
+       # Bug 578750
+       if use kernel_linux; then
+               linux-info_pkg_setup
+               if ! linux_config_exists; then
+                       ewarn "Can't check the linux kernel configuration."
+                       ewarn "You might be missing vsyscall support."
+               elif   kernel_is -ge 4 4 \
+                   && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+                       ewarn "You do not have vsyscall emulation enabled."
+                       ewarn "This will prevent some boinc projects from running."
+                       ewarn "Please enable vsyscall emulation:"
+                       ewarn "    CONFIG_LEGACY_VSYSCALL_EMULATE=y"
+                       ewarn "in /usr/src/linux/.config, to be found at"
+                       ewarn "    Processor type and features --->"
+                       ewarn "        vsyscall table for legacy applications (None) --->"
+                       ewarn "            (X) Emulate"
+                       ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
+                       ewarn "However, this has security implications and is not recommended."
+               fi
+       fi
+}
+
+src_prepare() {
+       # prevent bad changes in compile flags, bug 286701
+       sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
+
+       eautoreconf
+
+       use X && need-wxwidgets unicode
+}
+
+src_configure() {
+       econf --disable-server \
+               --enable-client \
+               --enable-dynamic-client-linkage \
+               --disable-static \
+               --enable-unicode \
+               --with-ssl \
+               $(use_with X x) \
+               $(use_enable X manager) \
+               $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
+}
+
+src_install() {
+       default
+
+       keepdir /var/lib/${PN}
+
+       if use X; then
+               newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png
+               make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+       fi
+
+       # cleanup cruft
+       rm -rf "${ED}"/etc || die "rm failed"
+
+       newinitd "${FILESDIR}"/${PN}.init ${PN}
+       newconfd "${FILESDIR}"/${PN}.conf ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_preinst() {
+       enewgroup ${PN}
+       # note this works only for first install so we have to
+       # elog user about the need of being in video group
+       local groups="${PN}"
+       if use cuda; then
+               group+=",video"
+       fi
+       enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
+}
+
+pkg_postinst() {
+       echo
+       elog "You are using the source compiled version of boinc."
+       use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
+       elog
+       elog "You need to attach to a project to do anything useful with boinc."
+       elog "You can do this by running /etc/init.d/boinc attach"
+       elog "The howto for configuration is located at:"
+       elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
+       elog
+       # Add warning about the new password for the client, bug 121896.
+       if use X; then
+               elog "If you need to use the graphical manager the password is in:"
+               elog "/var/lib/boinc/gui_rpc_auth.cfg"
+               elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+               elog "/etc/conf.d/boinc"
+               elog "You should change this password to something more memorable (can be even blank)."
+               elog "Remember to launch init script before using manager. Or changing the password."
+               elog
+       fi
+       if use cuda; then
+               elog "To be able to use CUDA you should add boinc user to video group."
+               elog "Run as root:"
+               elog "gpasswd -a boinc video"
+       fi
+}