dev-libs/cyberjack: add workaround for gcc10
authorConrad Kostecki <conikost@gentoo.org>
Thu, 14 May 2020 22:08:28 +0000 (00:08 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Thu, 14 May 2020 22:09:53 +0000 (00:09 +0200)
Add workaround for GCC-10, by defining narrowing as warning like GCC-9 did.
Upstream is informed, so hopefully there will be a proper fix in future.

Bug: https://bugs.gentoo.org/722962
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
dev-libs/cyberjack/cyberjack-3.99.5_p13.ebuild

index edde808059044492a5dd5beeb5bbbaefca8c64e0..97f2ad1beba3ce5f860234e35c93bfacd27ae976 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -7,7 +7,7 @@ MY_PN="pcsc-${PN}"
 MY_PV="${PV/_p/final.SP}"
 MY_P="${MY_PN}_${MY_PV}"
 
-inherit autotools linux-info toolchain-funcs udev
+inherit autotools flag-o-matic linux-info toolchain-funcs udev
 
 DESCRIPTION="REINER SCT cyberJack USB chipcard reader user space driver"
 HOMEPAGE="https://www.reiner-sct.de/"
@@ -32,6 +32,12 @@ S="${WORKDIR}/${MY_P/_/-}"
 
 CONFIG_CHECK="~USB_SERIAL_CYBERJACK"
 
+pkg_setup() {
+       # Add workaround for GCC-10,
+       # by defining narrowing as warning like GCC-9 did.
+       append-cxxflags -Wno-narrowing
+}
+
 src_prepare() {
        default