net-ftp/filezilla: 3.48.0 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 14:23:46 +0000 (16:23 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 14:25:00 +0000 (16:25 +0200)
Also patch build system to skip useless configure sub script (win-only
shell extension) that used default CC. Apply same patch to stable
candidate 3.47.2.1

Closes: https://bugs.gentoo.org/717736
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
net-ftp/filezilla/Manifest
net-ftp/filezilla/files/filezilla-3.47.0-disable-shellext_conf.patch [new file with mode: 0644]
net-ftp/filezilla/filezilla-3.47.2.1.ebuild
net-ftp/filezilla/filezilla-3.48.0.ebuild [new file with mode: 0644]

index a1ae050d5d7d0ba5a2716027bfe52502d3d132c9..b78827f5aea7317f0b7ea26abdde3cdee36314e1 100644 (file)
@@ -4,3 +4,4 @@ DIST FileZilla_3.45.1_src.tar.bz2 4649083 BLAKE2B 8d3113e5ce96d2115a6ec02109f261
 DIST FileZilla_3.46.3_src.tar.bz2 4720329 BLAKE2B 92369d2fb3b8c9eded37f912bbd25a0e995a5fc1ab86ef6aa746a8eb239f17e8fafa78de00529b0f3af102fe268b51a60ce40ac967cf9b2fbbd6fa7900898ffc SHA512 35b61c3bfd1d40848e7846b4533da8844df0e4873cb89286b90330cbc29dffeff96fcab10aec908a08d9129198bb2d80df8f223d8ebc1a0863a4083cb06abffc
 DIST FileZilla_3.47.1_src.tar.bz2 4732088 BLAKE2B 3db5247a9e2d9a7bf296091317b8faf049dbe9dca328536671dba5e5ab7b32d16d273348d0cbcf89342262a34dcf7d90198b4dfb98e67bfb683febf07b7b680e SHA512 32573e847bc23acb86bdea8eb4de102e4f673465e0b86738d954b47eacdf6e534854a9065bddf8b586eba315bf65b1bfc4f17f9379819a6c9bd43ae6ed8f388a
 DIST FileZilla_3.47.2.1_src.tar.bz2 4733941 BLAKE2B 0517d43bfba8aa116ae4031d56e5070aadbcaf81ace2311f6cfddb47e7f67ec62396ae3690c139bcc1a8368be690776b3163dd6d53a6ebb27ee5e99300b3c67b SHA512 8919eab7762e0e30241637a8978fbf61f02ac4c52aac293191315b931d52b41ae228b753f4e3b7530835578836dfee7f91772841273e9fc2bdf75ff7ed48fafc
+DIST FileZilla_3.48.0_src.tar.bz2 4765599 BLAKE2B 0ab391c0862a34dd5ede7a80290afc82b4d85b2deaf42d3bacd243bddf15505f05028522f73eeada07e91d91e0af87676ad77081c843448fda53c3b2ac18a70d SHA512 c9d4eb17dc31894468ca4b7c4c8fda0f307d3931bf1b3b8fb44afd084a1b2c9309d39e5745f9ba287a5566d44089af32350703e324a559afd6a015af469433fb
diff --git a/net-ftp/filezilla/files/filezilla-3.47.0-disable-shellext_conf.patch b/net-ftp/filezilla/files/filezilla-3.47.0-disable-shellext_conf.patch
new file mode 100644 (file)
index 0000000..55868dc
--- /dev/null
@@ -0,0 +1,13 @@
+diff -Naur filezilla-3.47.2.1.orig/configure.ac filezilla-3.47.2.1/configure.ac
+--- filezilla-3.47.2.1.orig/configure.ac       2020-03-11 12:24:12.000000000 +0100
++++ filezilla-3.47.2.1/configure.ac    2020-05-09 16:09:23.832476049 +0200
+@@ -130,9 +130,6 @@
+   "$ac_abs_confdir/src/fzshellext/configure" --prefix="$prefix" --exec-prefix="$exec_prefix" --host=i686-w64-mingw32 || exit 1
+   cd "$OLD_DIR/src/fzshellext/64" || exit 1
+   "$ac_abs_confdir/src/fzshellext/configure" --prefix="$prefix" --exec-prefix="$exec_prefix" --host=x86_64-w64-mingw32 || exit 1
+-else
+-  cd "$OLD_DIR/src/fzshellext/64" || exit 1
+-  "$ac_abs_confdir/src/fzshellext/configure" --disable-shellext || exit 1
+ fi
+ cd "$OLD_DIR"
index 9b6e1abcc9573cbdb386154d76c5ea49e7ac82b8..2d228d74462ff26a86bf8cc2bd8ef9147be00f00 100644 (file)
@@ -45,6 +45,7 @@ DOCS=(AUTHORS ChangeLog NEWS )
 PATCHES=(
        "${FILESDIR}"/${PN}-3.22.1-debug.patch
        "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+       "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
 )
 
 pkg_pretend() {
diff --git a/net-ftp/filezilla/filezilla-3.48.0.ebuild b/net-ftp/filezilla/filezilla-3.48.0.ebuild
new file mode 100644 (file)
index 0000000..9e6b4b3
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+       >=dev-libs/nettle-3.1:=
+       >=dev-db/sqlite-3.7
+       >=dev-libs/libfilezilla-0.21.0:=
+       <dev-libs/libfilezilla-0.22.0:=
+       >=dev-libs/pugixml-1.7
+       >=net-libs/gnutls-3.5.7
+       >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+       x11-misc/xdg-utils
+       dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       >=sys-devel/libtool-1.4
+       nls? ( >=sys-devel/gettext-0.11 )
+       test? ( >=dev-util/cppunit-1.13.0 )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.22.1-debug.patch
+       "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+       "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+)
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if ! test-flag-CXX -std=c++14; then
+                       eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+                       eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+                       eerror "to gcc-4.9 or an equivalent version supporting C++14."
+                       die "Currently active compiler does not support -std=c++14"
+               fi
+       fi
+}
+
+src_prepare() {
+       setup-wxwidgets
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --disable-autoupdatecheck
+               --with-pugixml=system
+               $(use_enable nls locales)
+               $(use_with dbus)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}