dev-python/hypothesis: Bump to version 3.6.1
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 22 Dec 2016 16:49:02 +0000 (17:49 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 22 Dec 2016 22:45:38 +0000 (23:45 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-3.6.1.ebuild [new file with mode: 0644]

index 246a11792d9a108d689c2ee63f638ef52a4130c8..c2a71786dea90c97fb445eccdb27656cbcf87cb3 100644 (file)
@@ -1,2 +1,3 @@
 DIST hypothesis-1.19.0.tar.gz 86227 SHA256 0e977a3492f5488ed9dd4a872cefae0934ad4ccd0229a6c483ef5ca0aaaddd6d SHA512 3b2cd671498bd0bc88c93b2753f35b02f737533dd8dbc786420a37a417d145e4f1c579741966394f85b7df4939e61f77315e6158b29e22f9bde07d31e161e009 WHIRLPOOL 52b444e6e3fa0c514ebb9816cd489b2441b213581e241f76ab5aa5c410ca08bedef92f0b608c32c421f74ba84a0e26850a2aaf9f2d9f7229aa176d9e501175a0
 DIST hypothesis-3.6.0.tar.gz 73586 SHA256 ecb0e711ab83032c54605d88fda1e07ca5c6025bdb5e91deab96eca29491f678 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389 WHIRLPOOL 189c788fdd0a326879a468061c271b14056da5f7dc1d5975e8f360cd5a91957eb8f79c26a045fbe49d7b11f7cc09024d3d09a353321b1dda1d4d96b452fd9e7b
+DIST hypothesis-3.6.1.tar.gz 75106 SHA256 d4a0aa584ee4654819b8bfc8b5791669ad229eb1db949716543d7c31219cb35b SHA512 89a884cfc147b09e6356ea1f2272784b256065a7ff86584c133c00d11cb0fda0a8463e347c15698c605f6c2d8fc7aa09cd4c216849cb2b851566bdf4268c28c4 WHIRLPOOL 1a65ad7442ba457390414c3117fdcde6981adb6e7cd0269b47ac7ec63e60393af386518f4ca79410222ff7533b12f87a99705f22fd9b20befdcf6a6a4a422e12
diff --git a/dev-python/hypothesis/hypothesis-3.6.1.ebuild b/dev-python/hypothesis/hypothesis-3.6.1.ebuild
new file mode 100644 (file)
index 0000000..8d93829
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.python.org/pypi/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pytest support" dev-python/pytest
+}