Cleanup, Vbump.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 18 Mar 2007 01:12:09 +0000 (01:12 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 18 Mar 2007 01:12:09 +0000 (01:12 +0000)
Package-Manager: portage-2.1.2.2

dev-php5/phpdbg/ChangeLog
dev-php5/phpdbg/files/digest-phpdbg-2.11.32 [deleted file]
dev-php5/phpdbg/files/digest-phpdbg-2.13.1 [deleted file]
dev-php5/phpdbg/files/digest-phpdbg-2.15.1 [new file with mode: 0644]
dev-php5/phpdbg/phpdbg-2.11.32.ebuild [deleted file]
dev-php5/phpdbg/phpdbg-2.15.1.ebuild [moved from dev-php5/phpdbg/phpdbg-2.13.1.ebuild with 64% similarity]

index cde316d250457f4b91dbddd0d98d69c864049a01..0772ba1c64356d6dfca2aac8b663957a44ab02ee 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-php5/phpdbg
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.7 2007/02/22 00:06:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.8 2007/03/18 01:12:09 chtekk Exp $
+
+*phpdbg-2.15.1 (18 Mar 2007)
+
+  18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> -phpdbg-2.11.32.ebuild,
+  -phpdbg-2.13.1.ebuild, +phpdbg-2.15.1.ebuild:
+  Version bump, cleanup, remove old versions.
 
   22 Feb 2007; Piotr JaroszyƄski <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
diff --git a/dev-php5/phpdbg/files/digest-phpdbg-2.11.32 b/dev-php5/phpdbg/files/digest-phpdbg-2.11.32
deleted file mode 100644 (file)
index 95d0e38..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1ac7372bfcb4c5e13cad1248e071d70c dbg-2.11.32-src.tar.gz 39369
-RMD160 21afe4bbcc92748410e619dd9e29c754dca8f543 dbg-2.11.32-src.tar.gz 39369
-SHA256 d25b8b06c347140f3e4909a41c26ad88ce70476a4ee7bc795d0b4e6168234408 dbg-2.11.32-src.tar.gz 39369
diff --git a/dev-php5/phpdbg/files/digest-phpdbg-2.13.1 b/dev-php5/phpdbg/files/digest-phpdbg-2.13.1
deleted file mode 100644 (file)
index 3a2dbe4..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 026cc9a088ec25a81cb206c6659309a6 dbg-2.13.1.tar.gz 337221
-RMD160 a3ca05158cc1edfed61b13b7249ee6f3d8133c61 dbg-2.13.1.tar.gz 337221
-SHA256 27b990c9e55165dd04feba8dfc0ecd51a76270fb97a08e395fedc150992e20f4 dbg-2.13.1.tar.gz 337221
diff --git a/dev-php5/phpdbg/files/digest-phpdbg-2.15.1 b/dev-php5/phpdbg/files/digest-phpdbg-2.15.1
new file mode 100644 (file)
index 0000000..cdcad8a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 537277ae275f3320a1e2728dccd6635f dbg-2.15.1.tar.gz 252087
+RMD160 668218b20351bfe6dace63a0aee8f387a56d4926 dbg-2.15.1.tar.gz 252087
+SHA256 c6faf95cbaf68407b2282a31f7faa51071fe485209efbdef1c77524b93b79afd dbg-2.15.1.tar.gz 252087
diff --git a/dev-php5/phpdbg/phpdbg-2.11.32.ebuild b/dev-php5/phpdbg/phpdbg-2.11.32.ebuild
deleted file mode 100644 (file)
index 0716201..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.11.32.ebuild,v 1.6 2007/01/28 06:37:27 genone Exp $
-
-PHP_EXT_NAME="dbg"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-DESCRIPTION="A PHP debugger useable with some editors like phpedit."
-SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}${PL}-src.tar.gz"
-HOMEPAGE="http://dd.cron.ru/dbg/"
-LICENSE="dbgphp"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/dbg-${PV}${PL}"
-
-need_php_by_category
-
-pkg_setup() {
-       has_php
-
-       # phpdbg does not work with Zend Thread Safety (ZTS)
-       # so abort if we are using PHP compiled with ZTS.
-       if has_zts ; then
-               eerror "phpdbg doesn't work with a ZTS enabled PHP."
-               eerror "Please disable ZTS by turning the 'threads'"
-               eerror "USE flag off when you compile dev-lang/php."
-               die "phpdbg does not support ZTS"
-       fi
-}
-
-src_compile() {
-       has_php
-
-       my_conf="--enable-dbg=shared --with-dbg-profiler"
-       php-ext-source-r1_src_compile
-}
-
-src_install() {
-       php-ext-source-r1_src_install
-       dodoc-php AUTHORS COPYING INSTALL
-       php-ext-base-r1_addtoinifiles "[Debugger]"
-       php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
-       php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
-}
-
-pkg_postinst() {
-       elog "Please reload Apache to activate the changes."
-}
-
-pkg_postrm() {
-       elog "You need to remove all lines referring to the debugger, and"
-       elog "extension=dbg.so. Please reload Apache to activate the changes."
-}
similarity index 64%
rename from dev-php5/phpdbg/phpdbg-2.13.1.ebuild
rename to dev-php5/phpdbg/phpdbg-2.15.1.ebuild
index 5015bba46b2e9ccbd3ceea5faeb8ea9af2b0e60f..e662ab4553ffc3054ed6c0f2d7486c5769b8e9bb 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.13.1.ebuild,v 1.2 2007/01/28 06:37:27 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.15.1.ebuild,v 1.1 2007/03/18 01:12:09 chtekk Exp $
 
 PHP_EXT_NAME="dbg"
 PHP_EXT_INI="yes"
@@ -9,22 +9,26 @@ PHP_EXT_ZENDEXT="no"
 inherit php-ext-source-r1
 
 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
 DESCRIPTION="A PHP debugger useable with some editors like phpedit."
-SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}${PL}.tar.gz"
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}.tar.gz"
 HOMEPAGE="http://dd.cron.ru/dbg/"
 LICENSE="dbgphp"
 SLOT="0"
 IUSE=""
 
-S="${WORKDIR}/dbg-${PV}${PL}"
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/dbg-${PV}"
 
 need_php_by_category
 
 pkg_setup() {
        has_php
 
-       # phpdbg does not work with Zend Thread Safety (ZTS)
-       # so abort if we are using PHP compiled with ZTS.
+       # phpdbg does not work with Zend Thread Safety (ZTS),
+       # so abort if we're using PHP compiled with ZTS.
        if has_zts ; then
                eerror "phpdbg doesn't work with a ZTS enabled PHP."
                eerror "Please disable ZTS by turning the 'threads'"
@@ -34,8 +38,6 @@ pkg_setup() {
 }
 
 src_compile() {
-       has_php
-
        my_conf="--enable-dbg=shared --with-dbg-profiler"
        php-ext-source-r1_src_compile
 }
@@ -43,16 +45,8 @@ src_compile() {
 src_install() {
        php-ext-source-r1_src_install
        dodoc-php AUTHORS COPYING INSTALL
+
        php-ext-base-r1_addtoinifiles "[Debugger]"
        php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
        php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
 }
-
-pkg_postinst() {
-       elog "Please reload Apache to activate the changes."
-}
-
-pkg_postrm() {
-       elog "You need to remove all lines referring to the debugger, and"
-       elog "extension=dbg.so. Please reload Apache to activate the changes."
-}