www-plugins/pdfjs: stable 2.1.266 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Wed, 25 Sep 2019 20:19:14 +0000 (22:19 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Wed, 25 Sep 2019 20:59:32 +0000 (22:59 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
www-plugins/pdfjs/Manifest
www-plugins/pdfjs/pdfjs-2.1.266.ebuild [new file with mode: 0644]

index 0a9454d66fea08458f91329d5925ea200535e1ad..4f4c97c3e99848b42486da2a6303683a6e01aa46 100644 (file)
@@ -1 +1,2 @@
 DIST pdfjs-1.9.426.zip 3510568 BLAKE2B dbeaa51fea45c6bb0a538e96c39cabb096720aa41d882fe01f0e11ec26d23ead918f4d2c09c9cce37606be9b059abe5902c9eb9ff018755cb2278a55481bc1ec SHA512 4c6a7ac613755a73d694a80ccea0d0d3d100fb0c7039ae5d866059d39e58b650092a733c7bea6d302cfa196f439d28f59055443ab96443161d1770462d8976ef
+DIST pdfjs-2.1.266.zip 4181305 BLAKE2B 2dd23d90ce660535b7abb8defce0788295e5a35093ec10afcad9d884f82a734c39363ad0607e00a24abf8e688153124d25b0c373d125226a2c8167880dc22bba SHA512 46695b0ebd000c75025fac96088bfe99b3a54f77908735084094759d82384b3348986211d536e8e80ded9a8497498bb1669579dfd9f653746ac5d9a80245a6a4
diff --git a/www-plugins/pdfjs/pdfjs-2.1.266.ebuild b/www-plugins/pdfjs/pdfjs-2.1.266.ebuild
new file mode 100644 (file)
index 0000000..8cf32af
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="https://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+       insinto /usr/share/pdf.js/
+
+       doins -r build
+       doins -r web
+}