dev-python/asdf: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:24:08 +0000 (20:24 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:24:08 +0000 (20:24 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/asdf/Manifest [deleted file]
dev-python/asdf/asdf-1.2.1.ebuild [deleted file]
dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch [deleted file]
dev-python/asdf/metadata.xml [deleted file]

diff --git a/dev-python/asdf/Manifest b/dev-python/asdf/Manifest
deleted file mode 100644 (file)
index 17534d2..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST asdf-1.2.1.tar.gz 320828 BLAKE2B 8050b24616ba56ac8d946a579da1a8962e54f22db45c8c95c45cccf4552355f68e6983c3831b60aa18d7c33a3914b1984ac31ce3461568bd5c4dee6625c113be SHA512 ac8b94ee1c0e2f1d99d55e38d13cd78e7fb14fbf8b5e15a725c61560e14ab96401a53909954ac6cde825121c6a1205b2d3b8ca474499b90461a2f0ebb5db4638
diff --git a/dev-python/asdf/asdf-1.2.1.ebuild b/dev-python/asdf/asdf-1.2.1.ebuild
deleted file mode 100644 (file)
index 5a7e8cb..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for the Advanced Scientific Data Format"
-HOMEPAGE="https://asdf.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/jsonschema[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-Disable-test-that-require-http-server.patch
-)
-
-python_prepare_all() {
-       # use system astropy-helpers instead of bundled one
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               PYTHONPATH="${BUILD_DIR}"/lib \
-                                 esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch b/dev-python/asdf/files/asdf-1.2.1-Disable-test-that-require-http-server.patch
deleted file mode 100644 (file)
index e59d482..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Ole Streicher <olebole@debian.org>
-Date: Sat, 5 Nov 2016 14:03:24 +0100
-Subject: Disable test that require http server
-
-Network connections are not available in pbuilder.
----
- asdf/tests/test_generic_io.py | 12 ++++--------
- 1 file changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/asdf/tests/test_generic_io.py b/asdf/tests/test_generic_io.py
-index 3f48eab..b90ca7e 100644
---- a/asdf/tests/test_generic_io.py
-+++ b/asdf/tests/test_generic_io.py
-@@ -241,8 +241,7 @@ def test_streams2():
-     assert len(x) == 60
--@pytest.mark.skipif(sys.platform.startswith('win'),
--                    reason="Windows firewall prevents test")
-+@pytest.mark.skipif(True, reason="pbuilder prevents test")
- def test_urlopen(tree, httpserver):
-     path = os.path.join(httpserver.tmpdir, 'test.asdf')
-@@ -260,8 +259,7 @@ def test_urlopen(tree, httpserver):
-         assert isinstance(next(ff.blocks.internal_blocks)._data, np.ndarray)
--@pytest.mark.skipif(sys.platform.startswith('win'),
--                    reason="Windows firewall prevents test")
-+@pytest.mark.skipif(True, reason="pbuilder prevents test")
- def test_http_connection(tree, httpserver):
-     path = os.path.join(httpserver.tmpdir, 'test.asdf')
-@@ -284,8 +282,7 @@ def test_http_connection(tree, httpserver):
-         ff.tree['science_data'][0] == 42
--@pytest.mark.skipif(sys.platform.startswith('win'),
--                    reason="Windows firewall prevents test")
-+@pytest.mark.skipif(True, reason="pbuilder prevents test")
- def test_http_connection_range(tree, rhttpserver):
-     path = os.path.join(rhttpserver.tmpdir, 'test.asdf')
-     connection = [None]
-@@ -348,8 +345,7 @@ def test_exploded_filesystem_fail(tree, tmpdir):
-                 helpers.assert_tree_match(tree, ff.tree)
--@pytest.mark.skipif(sys.platform.startswith('win'),
--                    reason="Windows firewall prevents test")
-+@pytest.mark.skipif(True, reason="pbuilder prevents test")
- def test_exploded_http(tree, httpserver):
-     path = os.path.join(httpserver.tmpdir, 'test.asdf')
diff --git a/dev-python/asdf/metadata.xml b/dev-python/asdf/metadata.xml
deleted file mode 100644 (file)
index d9905ab..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-     ASDF (Advanced Scientific Data Format) is a proposed
-     next generation interchange format for scientific data. ASDF aims to
-     exist in the same middle ground that made FITS so successful, by
-     being a hybrid text and binary format: containing human editable
-     metadata for interchange, and raw binary data that is fast to load
-     and use. Unlike FITS, the metadata is highly structured and is
-     designed up-front for extensibility.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">asdf</remote-id>
-    <remote-id type="github">spacetelescope/asdf</remote-id>    
-  </upstream>
-</pkgmetadata>