dev-python/fabric: drop py2.7 and other fixes
authorAaron Bauman <bman@gentoo.org>
Thu, 5 Dec 2019 01:28:16 +0000 (20:28 -0500)
committerAaron Bauman <bman@gentoo.org>
Thu, 5 Dec 2019 01:29:46 +0000 (20:29 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/fabric/fabric-2.3.1.ebuild

index 8265a2381332df360b8489832ad65cd1d875cf0a..430bb1ca83dd1ec12730cc921fb74d86ee1de164 100644 (file)
@@ -3,18 +3,20 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1
 
 DESCRIPTION="A simple pythonic tool for remote execution and deployment"
-HOMEPAGE="https://www.fabfile.org https://pypi.org/project/Fabric/"
+HOMEPAGE="https://www.fabfile.org https://pypi.org/project/fabric/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="2"
 KEYWORDS="~amd64 ~arm64 ~x86"
 IUSE="doc fab2"
+# Depends on pytest-relaxed which is not in tree
+RESTRICT="test"
 
 RDEPEND="
        !fab2? ( !dev-python/fabric:0 )
@@ -26,24 +28,21 @@ BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? (
                dev-python/alabaster[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.4[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
        )"
 
-# Depends on pytest-relaxed which is broken
-RESTRICT="test"
-
 python_compile() {
        if use fab2; then
                export PACKAGE_AS_FABRIC2=1
-               ln -s fabric fabric2 || die
+               ln -s fabric fabric2 || die "symlink create failed"
        fi
        distutils-r1_python_compile
 }
 
 python_compile_all() {
        if use doc; then
-               sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+               sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html \
+               || die "building docs failed"
        fi
 }