app-emulation/open-vm-tools: fix udev warnings
authorMike Gilbert <floppym@gentoo.org>
Fri, 20 Dec 2019 18:22:02 +0000 (13:22 -0500)
committerMike Gilbert <floppym@gentoo.org>
Fri, 20 Dec 2019 18:22:02 +0000 (13:22 -0500)
Package-Manager: Portage-2.3.82, Repoman-2.3.20_p9
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
app-emulation/open-vm-tools/files/11.0.1-udev-complaints.patch [new file with mode: 0644]
app-emulation/open-vm-tools/open-vm-tools-11.0.1-r1.ebuild [moved from app-emulation/open-vm-tools/open-vm-tools-11.0.1.ebuild with 98% similarity]

diff --git a/app-emulation/open-vm-tools/files/11.0.1-udev-complaints.patch b/app-emulation/open-vm-tools/files/11.0.1-udev-complaints.patch
new file mode 100644 (file)
index 0000000..b34e06d
--- /dev/null
@@ -0,0 +1,60 @@
+From f1dab8ded45aaaa4b6993a4d96d0aefc700f1796 Mon Sep 17 00:00:00 2001
+From: Oliver Kurth <okurth@vmware.com>
+Date: Mon, 28 Oct 2019 16:12:42 -0700
+Subject: [PATCH] stop systemd-243 udev complaints #371
+
+Address issues from pull request #371 on github:
+- fix substiution variables for systemd-243
+- fix permissions of rules file
+See https://github.com/vmware/open-vm-tools/pull/371
+---
+ open-vm-tools/AUTHORS                        | 4 ++++
+ open-vm-tools/udev/99-vmware-scsi-udev.rules | 6 +++---
+ open-vm-tools/udev/Makefile.am               | 4 ++--
+ 3 files changed, 9 insertions(+), 5 deletions(-)
+
+diff --git a/open-vm-tools/AUTHORS b/open-vm-tools/AUTHORS
+index 08cc28ef2..026de07e6 100644
+--- a/open-vm-tools/AUTHORS
++++ b/open-vm-tools/AUTHORS
+@@ -49,3 +49,7 @@ Josh Paetzel    Additional changes to vmmemctl.ko for FreeBSD 12.0 API changes.
+ Haruki Tsurumoto        Fix Asianux identification
+                 - https://github.com/vmware/open-vm-tools/pull/325
++
++MilhouseVH      stop systemd-243 udev complaints
++                - https://github.com/vmware/open-vm-tools/pull/371
++
+diff --git a/open-vm-tools/udev/99-vmware-scsi-udev.rules b/open-vm-tools/udev/99-vmware-scsi-udev.rules
+index 053b59706..fb4ed6844 100644
+--- a/open-vm-tools/udev/99-vmware-scsi-udev.rules
++++ b/open-vm-tools/udev/99-vmware-scsi-udev.rules
+@@ -1,7 +1,7 @@
+-# Copyright (C) 2016 VMware, Inc.  All rights reserved.
++# Copyright (C) 2016,2019 VMware, Inc.  All rights reserved.
+ #
+ # This file is part of open-vm-tools
+-ACTION=="add", SUBSYSTEMS=="scsi", ATTRS{vendor}=="VMware*", ATTRS{model}=="Virtual disk*", ENV{DEVTYPE}=="disk", RUN+="/bin/sh -c 'echo 180 >/sys$DEVPATH/device/timeout'"
+-ACTION=="add", SUBSYSTEMS=="scsi", ATTRS{vendor}=="VMware*", ATTRS{model}=="VMware Virtual S", ENV{DEVTYPE}=="disk", RUN+="/bin/sh -c 'echo 180 >/sys$DEVPATH/device/timeout'"
++ACTION=="add", SUBSYSTEMS=="scsi", ATTRS{vendor}=="VMware*", ATTRS{model}=="Virtual disk*", ENV{DEVTYPE}=="disk", RUN+="/bin/sh -c 'echo 180 >/sys$env{DEVPATH}/device/timeout'"
++ACTION=="add", SUBSYSTEMS=="scsi", ATTRS{vendor}=="VMware*", ATTRS{model}=="VMware Virtual S", ENV{DEVTYPE}=="disk", RUN+="/bin/sh -c 'echo 180 >/sys$env{DEVPATH}/device/timeout'"
+diff --git a/open-vm-tools/udev/Makefile.am b/open-vm-tools/udev/Makefile.am
+index 68fbc3e27..c3baadf16 100644
+--- a/open-vm-tools/udev/Makefile.am
++++ b/open-vm-tools/udev/Makefile.am
+@@ -1,5 +1,5 @@
+ ################################################################################
+-### Copyright (C) 2016 VMware, Inc.  All rights reserved.
++### Copyright (C) 2016,2019 VMware, Inc.  All rights reserved.
+ ###
+ ### This program is free software; you can redistribute it and/or modify
+ ### it under the terms of version 2 of the GNU General Public License as
+@@ -17,5 +17,5 @@
+ install-data-local:
+       $(INSTALL) -d $(DESTDIR)$(UDEVRULESDIR)
+-      $(INSTALL) $(srcdir)/99-vmware-scsi-udev.rules $(DESTDIR)$(UDEVRULESDIR)
++      $(INSTALL) -m 644 $(srcdir)/99-vmware-scsi-udev.rules $(DESTDIR)$(UDEVRULESDIR)
similarity index 98%
rename from app-emulation/open-vm-tools/open-vm-tools-11.0.1.ebuild
rename to app-emulation/open-vm-tools/open-vm-tools-11.0.1-r1.ebuild
index d86104a2c508d1451dd142da84d2d510fa48d50c..3fb3beb6d1d36b61a705f8316988f67914de31cd 100644 (file)
@@ -69,6 +69,7 @@ S="${WORKDIR}/${MY_P}"
 PATCHES=(
        "${FILESDIR}/10.1.0-mount.vmhgfs.patch"
        "${FILESDIR}/10.1.0-Werror.patch"
+       "${FILESDIR}/11.0.1-udev-complaints.patch"
 )
 
 pkg_setup() {