media-gfx/dmtx-utils: version bump to 0.7.6
authorAndrey Mazo <ahippo@yandex.com>
Sun, 6 Oct 2019 17:04:33 +0000 (20:04 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 13 Oct 2019 12:35:53 +0000 (15:35 +0300)
Closes: https://bugs.gentoo.org/696438
Closes: https://github.com/gentoo/gentoo/pull/13191
Package-Manager: Portage-2.3.76, Repoman-2.3.11

Signed-off-by: Andrey Mazo <ahippo@yandex.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-gfx/dmtx-utils/Manifest
media-gfx/dmtx-utils/dmtx-utils-0.7.6.ebuild [new file with mode: 0644]

index a83f1b43702e0040645d33be3484298390b4bfe5..e08df689b14b2ab5862aa56ebec422e2b8c7015e 100644 (file)
@@ -1 +1,2 @@
 DIST dmtx-utils-0.7.5.tar.gz 54754 BLAKE2B 0eaaa75dd8f650492f790aa960a6df93509e2bf5b1d0dd4b335a418f1524ee633d8d5f087cfef8b8950fc736dbb8ff702561e48506fa1b85d5846cf87601a197 SHA512 915104150d1cc5877d3012cb3934163b4a8e93f8132082835e8d12a8844d29e4afa06d020f5bd79e4bcacb8c153baadf183885619b7c4eb235d8c8c7041d325a
+DIST dmtx-utils-0.7.6.tar.gz 54888 BLAKE2B 721d67f85e73d245595d189acf1f974b518b079d02b7c57fa786b15ed075bd08219a2720b5152341449d517eb93e238274b440388557a64056de6cf6db9fc392 SHA512 201f8f5bbe5a1edd23104883d03e09842252ad7d07dd416b67c11740275ebe32c26b7fde904fad8bf2b18f1b3f574dedde1cc85f0e987f93d293d030e4f8a79e
diff --git a/media-gfx/dmtx-utils/dmtx-utils-0.7.6.ebuild b/media-gfx/dmtx-utils/dmtx-utils-0.7.6.ebuild
new file mode 100644 (file)
index 0000000..c7e9871
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for reading and writing Data Matrix barcodes"
+HOMEPAGE="https://github.com/dmtx/dmtx-utils"
+SRC_URI="https://github.com/dmtx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires libdmtx-0.7.5 due to DmtxPropFnc1
+RDEPEND="
+       >=media-gfx/imagemagick-6.2.4:=
+       >=media-libs/libdmtx-0.7.5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+
+       eautoreconf
+}