dev-python/pillow: Bump to 7.1.1
authorMichał Górny <mgorny@gentoo.org>
Fri, 3 Apr 2020 20:07:23 +0000 (22:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 3 Apr 2020 20:24:56 +0000 (22:24 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pillow/Manifest
dev-python/pillow/pillow-7.1.1.ebuild [new file with mode: 0644]

index aa5451c56ce4539fae076179d476dc5b86be8769..d9dcb996f382b5fbc48b440d88ba54ba14665130 100644 (file)
@@ -1,3 +1,4 @@
 DIST pillow-6.2.1.tar.gz 37405020 BLAKE2B bf3592bcc159902acc35899463c8949daf7cc31f03283684dc55d5f1517fdfbc07e1feb73b65b0b9cb4052ee1d5281558b38f9bd08240d0fc5727909b98da158 SHA512 ee757ec2b8382d6d56fd0f0cdd4cd36440cc37f05741e27fc661449a16dc7c868966772060adb283de1b1b5ebc49b8eec46e0bdcdad9f5f4d5ebd77feab7ad31
 DIST pillow-6.2.2.tar.gz 37538464 BLAKE2B dfd9b81490a8adb4e12ecbf6764e4e27573c9a087877ac37275a9fb42b89f0cd8cab8d7ca0b45c9a00bf38ca5b1d83de68f5fc35ff19031bfcc1495ee3a5f5b7 SHA512 0f2c3bfd921247fa11645eadc42e184182a401ccbdb8f10215312e96c8c28f2382f5413b56acd78fab1dffc6fa53cc8588ce960543af65c4769451874c2c918e
 DIST pillow-7.0.0.tar.gz 37880130 BLAKE2B be940cbdced884c33f2b3979be113b1bc8974814c9532fe80203395184f90eccba1cd9a5017fec1f0c30a21ff06abc46560d5c6d67938dbf640f2e8e08b7e554 SHA512 187173a525d4f3f01b4898633263b53a311f337aa7b159c64f79ba8c7006fd44798a058e7cc5d8f1116bad008e4142ff303456692329fe73b0e115ef5c225d73
+DIST pillow-7.1.1.tar.gz 38933780 BLAKE2B 411e97f7ae26361501e51c1756d9c495b8fe893fdd7eeea5f51e83aab99b04216e9518f54a69a57b482b3f6837a1318daed2963f196fa5c6166d71cb7bba281e SHA512 1f3c0a3c604e95ac60e2b9170fd2f45156a444a2f98dc3afe523178364a38e2f33ca8e312be85d2ec7a13c461236063dc2622db8df7ad7fe393aeb98b5bf2dfa
diff --git a/dev-python/pillow/pillow-7.1.1.ebuild b/dev-python/pillow/pillow-7.1.1.ebuild
new file mode 100644 (file)
index 0000000..43f8084
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg tiff )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/olefile[${PYTHON_USEDEP}]
+       imagequant? ( media-gfx/libimagequant:0 )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( media-libs/openjpeg:2= )
+       lcms? ( media-libs/lcms:2= )
+       tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+       truetype? ( media-libs/freetype:2= )
+       webp? ( media-libs/libwebp:0= )
+       xcb? ( x11-libs/libxcb )
+       zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               media-gfx/imagemagick[png]
+       )
+"
+
+distutils_enable_sphinx docs \
+       dev-python/sphinx_rtd_theme
+
+python_configure_all() {
+       # It's important that these flags are also passed during the install phase
+       # as well. Make sure of that if you change the lines below. See bug 661308.
+       mydistutilsargs=(
+               build_ext
+               --disable-platform-guessing
+               $(use_enable truetype freetype)
+               $(use_enable jpeg)
+               $(use_enable jpeg2k jpeg2000)
+               $(use_enable lcms)
+               $(use_enable tiff)
+               $(use_enable imagequant)
+               $(use_enable webp)
+               $(use_enable webp webpmux)
+               $(use_enable xcb)
+               $(use_enable zlib)
+       )
+
+       # setup.py sucks at adding the right toolchain paths but it does
+       # accept additional ones from INCLUDE and LIB so set these. You
+       # wouldn't normally need these at all as the toolchain should look
+       # here anyway but this setup.py does stupid things.
+       export \
+               INCLUDE=${ESYSROOT}/usr/include \
+               LIB=${ESYSROOT}/usr/$(get_libdir)
+
+       # We have patched in this env var.
+       tc-export PKG_CONFIG
+}
+
+src_test() {
+       virtx distutils-r1_src_test
+}
+
+python_test() {
+       "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+       # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+       pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+       python_doheader src/libImaging/*.h
+       distutils-r1_python_install
+}
+
+python_install_all() {
+       if use examples ; then
+               docinto example
+               dodoc docs/example/*
+               docompress -x /usr/share/doc/${PF}/example
+       fi
+       distutils-r1_python_install_all
+}