sys-libs/ncurses: fix header mismatch with multilib installs #557360
authorMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 13:54:05 +0000 (09:54 -0400)
committerMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 13:55:04 +0000 (09:55 -0400)
The progs change had a subtle effect that broke multilib builds.
A few ticlib headers aren't installed when progs are disabled.
Add a patch to always install them regardless of the progs state.

profiles/package.mask
sys-libs/ncurses/files/ncurses-6.0-ticlib.patch [new file with mode: 0644]
sys-libs/ncurses/ncurses-6.0.ebuild

index 21e8a4e738f73b815aceea5c9a58b8584885df7c..01d9b69e5bb3183e47213ecaf39132c2992c74f9 100644 (file)
 
 #--- END OF EXAMPLES ---
 
-# Lars Wendler <polynomial-c@gentoo.org> (12 Aug 2015)
-# Masked due to ABI_X86="32" breakage (bug #557360)
-=sys-libs/ncurses-6.0
-
 # Patrice Clement <monsieurp@gentoo.org> (11 Aug 2015)
 # Old and doesn't compile with recent JDKs (>= 1.8).
 # Masked for removal in 30 days. See bug #557210.
diff --git a/sys-libs/ncurses/files/ncurses-6.0-ticlib.patch b/sys-libs/ncurses/files/ncurses-6.0-ticlib.patch
new file mode 100644 (file)
index 0000000..188e6ad
--- /dev/null
@@ -0,0 +1,15 @@
+always include ticlib even when progs are disabled
+
+https://bugs.gentoo.org/557360
+
+--- a/configure
++++ b/configure
+@@ -21312,7 +21312,7 @@ echo "$as_me:21311: checking for library subsets" >&5
+ echo $ECHO_N "checking for library subsets... $ECHO_C" >&6
+ LIB_SUBSETS=
+-if test "x$cf_with_progs" = xyes || test "$with_ticlib" != no || test "$with_termcap" != no; then
++if true; then
+       LIB_SUBSETS="${LIB_SUBSETS}ticlib"
+       if test "$with_ticlib" != no ; then
+               LIB_SUBSETS="${LIB_SUBSETS} "
index a73d58f8f1ef13c6e81b921bc6bc8b73070ce6a5..898956c774f1102724fb6848bda481ef1e8c830e 100644 (file)
@@ -34,6 +34,7 @@ PATCHES=(
        "${FILESDIR}/${PN}-6.0-rxvt-unicode-9.15.patch" #192083 #383871
        "${FILESDIR}/${PN}-6.0-pkg-config.patch"
        "${FILESDIR}/${PN}-5.9-gcc-5.patch" #545114
+       "${FILESDIR}/${PN}-6.0-ticlib.patch" #557360
 )
 
 src_prepare() {