dev-tcltk/tkpiechart: EAPI 7
authorTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:50:06 +0000 (15:50 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:50:06 +0000 (15:50 +0200)
Bugs: https://bugs.gentoo.org/697338
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild
dev-tcltk/tkpiechart/tkpiechart-6.5-r2.ebuild [new file with mode: 0644]

index ca9a67327bfae7b972c57dc5a4beba7eb56560bc..4df808b2fe79de952d2d32d325b91d0fdc09faca 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=0
@@ -16,6 +16,7 @@ IUSE=""
 
 DEPEND=">=dev-lang/tk-8.3
        dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
 
 src_install() {
        dodir /usr/$(get_libdir)/tkpiechart
diff --git a/dev-tcltk/tkpiechart/tkpiechart-6.5-r2.ebuild b/dev-tcltk/tkpiechart/tkpiechart-6.5-r2.ebuild
new file mode 100644 (file)
index 0000000..de6b807
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="create and update 2D or 3D pie charts in a Tcl/Tk application"
+HOMEPAGE="http://jfontain.free.fr/piechart6.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="jfontain"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/tk:*
+       dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       dodir /usr/$(get_libdir)/tkpiechart
+       ./instapkg.tcl "${D}"/usr/$(get_libdir)/tkpiechart || die
+
+       HTML_DOCS=( *.gif *.htm )
+       einstalldocs
+       docinto demo
+       dodoc demo*
+       docompress -x /usr/share/doc/${PF}/demo
+}